aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-09 13:52:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-09 13:52:09 -0300
commitfd87a1def726d8e9d5f25d65f4ea95b75e17949f (patch)
treefb84302d5c7610edb02fbf37ae9cc5d2de60af77
parent8ffbd5299a8bda1b1c2fad29ff867177c937ccf2 (diff)
downloadaports-fd87a1def726d8e9d5f25d65f4ea95b75e17949f.tar.bz2
aports-fd87a1def726d8e9d5f25d65f4ea95b75e17949f.tar.xz
testing/py3-weasyprint: fix url fix license fix replaces add provides
-rw-r--r--testing/py3-weasyprint/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/testing/py3-weasyprint/APKBUILD b/testing/py3-weasyprint/APKBUILD
index 663c4ec62b..ff7e0be127 100644
--- a/testing/py3-weasyprint/APKBUILD
+++ b/testing/py3-weasyprint/APKBUILD
@@ -2,34 +2,32 @@
pkgname=py3-weasyprint
_pyname=WeasyPrint
pkgver=46
-pkgrel=0
+pkgrel=1
pkgdesc="cairo-based HTML renderer for python"
-url="http://weasyprint.org"
+url="https://weasyprint.org"
arch="noarch"
-license="LGPL"
+license="BSD-3-Clause"
depends="
pango cairo py3-cairocffi py3-cairosvg py3-cssselect2 py3-tinycss2 py3-pyphen
py3-lxml py3-pdfrw
"
-makedepends="python3-dev py-setuptools"
+makedepends="py3-setuptools"
_pypiprefix="${_pyname%${_pyname#?}}"
source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
builddir="$srcdir"/$_pyname-$pkgver
-replaces="py-weasyprint py2-weasyprint"
+
+replaces="py-weasyprint" # Backwards compat
+provides="py-weasyprint=$pkgver-r$pkgrel" # Backwards compat
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 setup.py check
}
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}