aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2018-01-06 14:37:44 -0500
committerDaniel Sabogal <dsabogalcc@gmail.com>2018-01-07 12:55:00 -0500
commit3ea997b3eccec83d8e3e49d6b29650a79e62bb86 (patch)
tree45a9b64ba8894eca15c9ad9b3a354927b6fd49d3
parent7222accc7e044ef10f13b61480c0aa5bca86628c (diff)
downloadaports-3ea997b3eccec83d8e3e49d6b29650a79e62bb86.tar.bz2
aports-3ea997b3eccec83d8e3e49d6b29650a79e62bb86.tar.xz
testing/csmith: new aport
https://embed.cs.utah.edu/csmith/ Tool for generating random C programs
-rw-r--r--testing/csmith/APKBUILD35
-rw-r--r--testing/csmith/fix-s390x-read_time.patch12
-rw-r--r--testing/csmith/support-ppc64le.patch28
3 files changed, 75 insertions, 0 deletions
diff --git a/testing/csmith/APKBUILD b/testing/csmith/APKBUILD
new file mode 100644
index 0000000000..d1cba97059
--- /dev/null
+++ b/testing/csmith/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=csmith
+pkgver=2.3.0
+pkgrel=0
+pkgdesc="Tool for generating random C programs"
+url="https://embed.cs.utah.edu/csmith/"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+makedepends="m4"
+subpackages="$pkgname-doc"
+options="!check" # no test suite
+source="https://embed.cs.utah.edu/csmith/$pkgname-$pkgver.tar.gz
+ support-ppc64le.patch
+ fix-s390x-read_time.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ # scripts depend on source tree to be available
+ rm "$pkgdir"/usr/bin/*.pl "$pkgdir"/usr/bin/*.in
+}
+
+sha512sums="abab6ace0fa6b1be248c3ffbac7069bcadbad7b7af5673660849c8bebf84de040afcf527b2fefbbcb68b9164a43e08684c147496fb2b25bbffef7495dba39041 csmith-2.3.0.tar.gz
+eb91f89577b583b4a6200ae4b804577217ff71c5dfa956ac28b64a3556cdafec2c43a231770d68f2a50737a78f8e5981f6ceeed1e90c49d4218fde6a7b302c6c support-ppc64le.patch
+a81623231bc917166a49370f3a3a48f4dd4f7a1b1573548c110e6aad31be64fadbf509c595c15c1ccedb881a735dac4e15a6a32385524c1eaa04a87eb6523fe7 fix-s390x-read_time.patch"
diff --git a/testing/csmith/fix-s390x-read_time.patch b/testing/csmith/fix-s390x-read_time.patch
new file mode 100644
index 0000000000..8074f2b1a4
--- /dev/null
+++ b/testing/csmith/fix-s390x-read_time.patch
@@ -0,0 +1,12 @@
+http://bugs.debian.org/872604
+--- csmith-2.3.0/src/platform.cpp.orig
++++ csmith-2.3.0/src/platform.cpp
+@@ -79,7 +79,7 @@
+ static unsigned long long read_time(void)
+ {
+ unsigned long long clk;
+- asm volatile("stckf %0" : "=Q" (clk) : : "cc");
++ asm volatile("stck %0" : "=Q" (clk) : : "cc");
+ return clk;
+ }
+ # elif defined(__i386__) || defined(__x86_64__)
diff --git a/testing/csmith/support-ppc64le.patch b/testing/csmith/support-ppc64le.patch
new file mode 100644
index 0000000000..3488ad3be0
--- /dev/null
+++ b/testing/csmith/support-ppc64le.patch
@@ -0,0 +1,28 @@
+From c05ee1d3edfba74e61404666de4f251b42020062 Mon Sep 17 00:00:00 2001
+From: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
+Date: Tue, 21 Nov 2017 08:32:25 +0900
+Subject: [PATCH] Add support powerpc64le
+
+This supports little endian of powerpc64.
+
+Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
+---
+ src/platform.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/platform.cpp b/src/platform.cpp
+index 248ae6e..ff69361 100644
+--- a/src/platform.cpp
++++ b/src/platform.cpp
+@@ -57,7 +57,7 @@
+ // from the current time.
+ //
+ #ifndef HAVE_ARC4RANDOM_BUF
+-# if defined(__powerpc__) || defined(__powerpc64__)
++# if defined(__powerpc__) || defined(__powerpc64__) || defined(__powerpc64le__)
+ static inline unsigned long read_time(void)
+ {
+ unsigned long a;
+--
+2.15.0
+