aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-22 06:51:12 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-26 18:16:18 +0000
commit4be0ed78e4add1ca75afafe593889b285ce73c33 (patch)
treefb49a78bc9406573901472d8050deac86ee93198
parentfce239fc0daf25c214444cdc985d7f107315df8e (diff)
downloadaports-4be0ed78e4add1ca75afafe593889b285ce73c33.tar.bz2
aports-4be0ed78e4add1ca75afafe593889b285ce73c33.tar.xz
testing/masscan: new aport
-rw-r--r--testing/masscan/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/masscan/APKBUILD b/testing/masscan/APKBUILD
new file mode 100644
index 0000000000..73615b2c6a
--- /dev/null
+++ b/testing/masscan/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=masscan
+pkgver=1.0.5
+pkgrel=0
+pkgdesc="Mass IP port scanner - This is the fastest Internet port scanner."
+url="https://github.com/robertdavidgraham/masscan"
+arch="all"
+license="AGPL-3.0"
+depends="libpcap"
+makedepends="clang-dev libpcap-dev linux-headers"
+source="$pkgname-$pkgver.tar.gz::https://github.com/robertdavidgraham/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="55d58234994ebea10bcb3f45a24cdb51b020350faa116aee3a48861a119f66c339d1f533c978f52e37ccf5266be6fd2802765f13461d94eb28ec8d18c68e2f88 masscan-1.0.5.tar.gz"