aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-10 00:03:48 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-10 00:04:24 +0000
commita1e9c360f4c4301b93c7632cb86686ff296944ed (patch)
treec1ca54e1bdbb643db75fe6fc870fed4900cde347
parentea7953117b28cb6c533a5cbdb208a989b7590586 (diff)
downloadaports-a1e9c360f4c4301b93c7632cb86686ff296944ed.tar.bz2
aports-a1e9c360f4c4301b93c7632cb86686ff296944ed.tar.xz
testing/yara: keep using workaround in 3.7.0 version
-rw-r--r--testing/yara/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/testing/yara/APKBUILD b/testing/yara/APKBUILD
index 54dbc3ed97..b9e955bfb4 100644
--- a/testing/yara/APKBUILD
+++ b/testing/yara/APKBUILD
@@ -2,7 +2,7 @@
pkgname=yara
pkgver=3.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="The pattern matching swiss knife for malware researchers"
url="https://virustotal.github.io/yara/"
arch="all !armhf" # armhf: tests fail
@@ -12,6 +12,15 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/VirusTotal/$pkgname/archive/
subpackages="$pkgname-doc"
builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ default_prepare
+ # Delete re_lexer.c to force it to be build with new version
+ # of flex, othwewise tests fail in some arches because of a bug
+ # in older version of flex.
+ # See: https://github.com/VirusTotal/yara/issues/771
+ rm "$srcdir"/yara-3.6.3/libyara/re_lexer.c
+}
+
build() {
cd "$builddir"
autoreconf -fiv