aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-06 20:38:20 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-07 12:19:23 +0200
commite0cf3181e8319b1657ed3f39524dd4b6b3c7a7a5 (patch)
treeec909e7f62bb4c1ad99dbe55c50bfeb2236c994e
parenta13b023b35017eee9a9a254429f0ac4d1850bf38 (diff)
downloadaports-e0cf3181e8319b1657ed3f39524dd4b6b3c7a7a5.tar.bz2
aports-e0cf3181e8319b1657ed3f39524dd4b6b3c7a7a5.tar.xz
travis: fix changed_abuilds() to ignore deleted APKBUILDs
-rwxr-xr-x.travis/build-pkgs7
1 files changed, 4 insertions, 3 deletions
diff --git a/.travis/build-pkgs b/.travis/build-pkgs
index 75fc444674..c3f2bb79e2 100755
--- a/.travis/build-pkgs
+++ b/.travis/build-pkgs
@@ -22,9 +22,10 @@ changed_abuilds() {
local repo="$1"
local commit_ish="$2"
- # Get names of repo's subdirectories with modified APKBUILD.
- local aports="$(git diff-tree -r --relative="$repo" --name-only "$commit_ish" -- '*APKBUILD' \
- | xargs -I% dirname % | xargs)"
+ # Get names of repo's subdirectories with modified APKBUILD,
+ # but ignore deleted ones.
+ local aports="$(git diff-tree -r --relative="$repo" --name-only --diff-filter=ACMR \
+ "$commit_ish" -- '*APKBUILD' | xargs -I% dirname % | xargs)"
# Sort abuilds by build order.
ap builddirs -d "$(pwd)/$repo" $aports 2>/dev/null | xargs -I% basename %