aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-03-26 14:21:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-26 14:23:10 +0000
commite462ed0aa2eb4c2049f6b20a56b54f6bd7c90644 (patch)
treeb1631eed7323877474fb91230133b967acdf1377
parent487b0fdfef321fa9b68f399bd8cc561d1721ed9a (diff)
downloadaports-e462ed0aa2eb4c2049f6b20a56b54f6bd7c90644.tar.bz2
aports-e462ed0aa2eb4c2049f6b20a56b54f6bd7c90644.tar.xz
main/fftw: re-enable build for s390x
we disable HAVE_TICK_COUNTER
-rw-r--r--main/fftw/APKBUILD5
-rw-r--r--main/fftw/cycle.h.patch35
2 files changed, 32 insertions, 8 deletions
diff --git a/main/fftw/APKBUILD b/main/fftw/APKBUILD
index 881ed5d644..23ed395dd4 100644
--- a/main/fftw/APKBUILD
+++ b/main/fftw/APKBUILD
@@ -5,8 +5,7 @@ pkgver=3.3.6p2
pkgrel=2
pkgdesc="fastest fourier transform in the west"
url="http://www.fftw.org/"
-# s390x: hangs on container and KVM
-arch="all !s390x"
+arch="all"
license="GPL-2.0+"
makedepends="texinfo"
# order of the libs split functions are important because of lib naming
@@ -95,4 +94,4 @@ long_double() {
}
sha512sums="e130309856752a1555b6d151c4d0ce9eb4b2c208fff7e3e89282ca8ef6104718f865cbb5e9c4af4367b3615b69b0d50fd001a26d74fd5324ff2faabe14fe3472 fftw-3.3.6-pl2.tar.gz
-d71ffb0aa658f7b22239491698426f4a97e657abc953020745f7581d2937a062a279eaa5980cd7f7fe2e8425a032eafc3d4c0cffdc79a83a3aef382c988d739a cycle.h.patch"
+522b57654401372d219be58e4566c1d7b9f691ead8ae6c718ecff3edccb2a5b9db9afb763acb85ec63b26a17099b1826a0680b4010973ac84a66116c3f80422b cycle.h.patch"
diff --git a/main/fftw/cycle.h.patch b/main/fftw/cycle.h.patch
index ff70cdb4d9..2b2adde334 100644
--- a/main/fftw/cycle.h.patch
+++ b/main/fftw/cycle.h.patch
@@ -1,9 +1,35 @@
---- ./kernel/cycle.h.orig
-+++ ./kernel/cycle.h
-@@ -437,26 +437,6 @@
+diff --git a/kernel/cycle.h b/kernel/cycle.h
+index a0e86f3..3ff4c0e 100644
+--- a/kernel/cycle.h
++++ b/kernel/cycle.h
+@@ -368,22 +368,6 @@ INLINE_ELAPSED(inline)
#define HAVE_TICK_COUNTER
#endif
+
+-/*----------------------------------------------------------------*/
+-/* S390, courtesy of James Treacy */
+-#if defined(__GNUC__) && defined(__s390__) && !defined(HAVE_TICK_COUNTER)
+-typedef unsigned long long ticks;
+-
+-static __inline__ ticks getticks(void)
+-{
+- ticks cycles;
+- __asm__("stck 0(%0)" : : "a" (&(cycles)) : "memory", "cc");
+- return cycles;
+-}
+-
+-INLINE_ELAPSED(__inline__)
+-
+-#define HAVE_TICK_COUNTER
+-#endif
/*----------------------------------------------------------------*/
+ #if defined(__GNUC__) && defined(__alpha__) && !defined(HAVE_TICK_COUNTER)
+ /*
+@@ -436,26 +420,6 @@ INLINE_ELAPSED(__inline)
+
+ #define HAVE_TICK_COUNTER
+ #endif
+-/*----------------------------------------------------------------*/
-/* SGI/Irix */
-#if defined(HAVE_CLOCK_GETTIME) && defined(CLOCK_SGI_CYCLE) && !defined(HAVE_TICK_COUNTER)
-typedef struct timespec ticks;
@@ -23,7 +49,6 @@
-#define HAVE_TICK_COUNTER
-#endif
-
--/*----------------------------------------------------------------*/
+ /*----------------------------------------------------------------*/
/* Cray UNICOS _rtc() intrinsic function */
#if defined(HAVE__RTC) && !defined(HAVE_TICK_COUNTER)
- #ifdef HAVE_INTRINSICS_H