aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCág <ca6c@bitmessage.ch>2017-11-08 18:32:01 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-09 13:20:53 +0000
commitf22c97ead265091b6226d90c1276a7e5f8166e3d (patch)
tree8328784cba166a02b8ffaf7b1086b91c40282f4c
parent8c9aa20b2f1445d63a2923145fffca1b40f1470a (diff)
downloadaports-f22c97ead265091b6226d90c1276a7e5f8166e3d.tar.bz2
aports-f22c97ead265091b6226d90c1276a7e5f8166e3d.tar.xz
testing/cwm: new aport
-rw-r--r--testing/cwm/APKBUILD29
-rw-r--r--testing/cwm/menu-border.patch13
2 files changed, 42 insertions, 0 deletions
diff --git a/testing/cwm/APKBUILD b/testing/cwm/APKBUILD
new file mode 100644
index 0000000000..8d2c8009d4
--- /dev/null
+++ b/testing/cwm/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Cág <ca6c@bitmessage.ch>
+# Maintainer: Cág <ca6c@bitmessage.ch>
+pkgname=cwm
+pkgver=6.2
+pkgrel=0
+pkgdesc="A lightweight and efficient window manager for X11"
+url="https://github.com/chneukirchen/cwm"
+arch="all"
+license="ISC"
+depends=""
+makedepends="libx11-dev libxft-dev libxrandr-dev byacc bsd-compat-headers"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/chneukirchen/$pkgname/archive/v$pkgver.tar.gz
+ menu-border.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+}
+
+sha512sums="aa892bd5b47de7332bee56b6980454b5064125b1d43571d16c1bd008b5a3ff99d9964934e5bfc372dd60ce512439ea45438ab7c29f70fb21131803dbc2d8b92f cwm-6.2.tar.gz
+d83c250af671de4d3ba9fcec6b1f72dfa9c36962e392521315987088f04c76830aef49a91f8e63f7be3e3895e3bf8ef0cc874c8ebb9e6e541accd2fae70fe2b8 menu-border.patch"
diff --git a/testing/cwm/menu-border.patch b/testing/cwm/menu-border.patch
new file mode 100644
index 0000000000..290b60576a
--- /dev/null
+++ b/testing/cwm/menu-border.patch
@@ -0,0 +1,13 @@
+diff --git a/conf.c b/conf.c
+index d750c42..20a2da5 100644
+--- a/conf.c
++++ b/conf.c
+@@ -478,7 +478,7 @@ conf_screen(struct screen_ctx *sc)
+
+ sc->menu.win = XCreateSimpleWindow(X_Dpy, sc->rootwin, 0, 0, 1, 1,
+ Conf.bwidth,
+- sc->xftcolor[CWM_COLOR_MENU_FG].pixel,
++ sc->xftcolor[CWM_COLOR_BORDER_ACTIVE].pixel,
+ sc->xftcolor[CWM_COLOR_MENU_BG].pixel);
+
+ sc->menu.xftdraw = XftDrawCreate(X_Dpy, sc->menu.win, visual, colormap);