aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-26 16:42:10 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-26 16:42:10 +0200
commitfcb540ab6978d3d5a55f08120c78d8e03b1e13c7 (patch)
tree16b2acf4adbaf54fafd7dd489e33d33c3a188c46 /Makefile
parenta2fa544ac6a75f93d809e3457432618dd89376dd (diff)
downloadaports-fcb540ab6978d3d5a55f08120c78d8e03b1e13c7.tar.bz2
aports-fcb540ab6978d3d5a55f08120c78d8e03b1e13c7.tar.xz
build: lua module build fixes
- do not link with -llua. We should not link apk or lua module with it. - default to lua 5.2 - allow override the lua version with LUA_VERSION - allow override the lua pkg-config package with LUA_PC - only add the pkg-config lua --cflags to the lua module
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index d7428f5d21..e34b05b447 100644
--- a/Makefile
+++ b/Makefile
@@ -15,9 +15,8 @@ LIBDIR := /lib
CONFDIR := /etc/apk
MANDIR := /usr/share/man
DOCDIR := /usr/share/doc/apk
-LUA_LIBDIR := /usr/lib/lua/5.1
-export DESTDIR SBINDIR LIBDIR CONFDIR MANDIR DOCDIR LUA_LIBDIR
+export DESTDIR SBINDIR LIBDIR CONFDIR MANDIR DOCDIR
##
# Top-level rules and targets