aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2012-01-03 07:51:02 +0000
committerAndrew Manison <amanison@anselsystems.com>2012-01-03 07:51:02 +0000
commit12ad231161f7f816c875ea3dd46d135fd20a5d1c (patch)
tree3daf8ecaa5428dece7099e6b64bb7657186b0b8c /Makefile
parent729bf5217292d082dcadf37a7e19424a156eca5d (diff)
downloadaports-12ad231161f7f816c875ea3dd46d135fd20a5d1c.tar.bz2
aports-12ad231161f7f816c875ea3dd46d135fd20a5d1c.tar.xz
aports tree: Removed QA build scripts to new repo
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile75
1 files changed, 0 insertions, 75 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index a85a3ff569..0000000000
--- a/Makefile
+++ /dev/null
@@ -1,75 +0,0 @@
-.PHONY: main testing non-free unstable
-
-rootdir := $(shell pwd)
-
-all: main testing non-free unstable
-
-apkbuilds := $(shell find . -maxdepth 3 -name APKBUILD -print)
-
-all-pkgs := $(sort $(subst ./,,$(patsubst %/,%,$(dir $(apkbuilds)))))
-
-main-pkgs := $(shell ./aport.lua deplist $(rootdir) main)
-
-testing-pkgs := $(shell ./aport.lua deplist $(rootdir) testing)
-
-non-free-pkgs := $(shell ./aport.lua deplist $(rootdir) non-free)
-
-unstable-pkgs := $(shell ./aport.lua deplist $(rootdir) unstable)
-
-main:
- for p in $(main-pkgs) ; \
- do \
- cd $(rootdir)/$@/$$p; \
- abuild -r; \
- done
-
-testing:
- for p in $(testing-pkgs) ; \
- do \
- cd $(rootdir)/$@/$$p; \
- abuild -r; \
- done
-
-non-free:
- for p in $(non-free-pkgs) ; \
- do \
- cd $(rootdir)/$@/$$p; \
- abuild -r; \
- done
-
-unstable:
- for p in $(unstable-pkgs) ; \
- do \
- cd $(rootdir)/$@/$$p; \
- abuild -r; \
- done
-
-clean:
- for p in $(all-pkgs) ; do \
- cd $(rootdir)/$$p; \
- abuild clean; \
- abuild cleanpkg; \
- done
-
-cleanold:
- for p in $(all-pkgs) ; do \
- cd $(rootdir)/$$p; \
- abuild cleanoldpkg; \
- done
-
-fetch:
- for p in $(all-pkgs) ; do \
- cd $(rootdir)/$$p; \
- abuild fetch; \
- done
-
-distclean:
- for p in $(all-pkgs) ; \
- do \
- cd $(rootdir)/$$p; \
- abuild clean; \
- abuild cleanoldpkg; \
- abuild cleanpkg; \
- abuild cleancache; \
- done
-