aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-04-02 19:37:03 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-04-02 19:37:03 +0000
commita050ffed38a8a17b4b1e7dcb6237800e7881a137 (patch)
treef9aaba4da11bd0d5a79852c78189d1cc6b157295 /Makefile
parent055b88dbf81b136286721fcbce7036616e5a41b3 (diff)
downloadaports-a050ffed38a8a17b4b1e7dcb6237800e7881a137.tar.bz2
aports-a050ffed38a8a17b4b1e7dcb6237800e7881a137.tar.xz
Added master makefile to build all packages.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile92
1 files changed, 92 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000000..993cc16a1a
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,92 @@
+.PHONY: main testing non-free unstable
+
+rootdir := $(shell pwd)
+
+all: main testing non-free unstable
+
+main-modules := $(sort \
+ $(notdir \
+ $(patsubst %/,%, \
+ $(dir \
+ $(shell find main -maxdepth 2 -name APKBUILD -print)))))
+
+testing-modules := $(sort \
+ $(notdir \
+ $(patsubst %/,%, \
+ $(dir \
+ $(shell find testing -maxdepth 2 -name APKBUILD -print)))))
+
+non-free-modules := $(sort \
+ $(notdir \
+ $(patsubst %/,%, \
+ $(dir \
+ $(shell find non-free -maxdepth 2 -name APKBUILD -print)))))
+
+unstable-modules := $(sort \
+ $(notdir \
+ $(patsubst %/,%, \
+ $(dir \
+ $(shell find unstable -maxdepth 2 -name APKBUILD -print)))))
+
+main:
+ for p in $(main-modules) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+testing:
+ for p in $(testing-modules) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+non-free:
+ for p in $(non-free-modules) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+unstable:
+ for p in $(unstable-modules) ; \
+ do \
+ cd $(rootdir)/$@/$$p; \
+ abuild -r; \
+ done
+
+clean:
+ for p in $(main-modules) ; \
+ do \
+ cd $(rootdir)/main/$$p; \
+ abuild clean; \
+ abuild cleanoldpkg; \
+ abuild cleanpkg; \
+ abuild cleancache; \
+ done
+ for p in $(testing-modules) ; \
+ do \
+ cd $(rootdir)/testing/$$p; \
+ abuild clean; \
+ abuild cleanoldpkg; \
+ abuild cleanpkg; \
+ abuild cleancache; \
+ done
+ for p in $(non-free-modules) ; \
+ do \
+ cd $(rootdir)/non-free/$$p; \
+ abuild clean; \
+ abuild cleanoldpkg; \
+ abuild cleanpkg; \
+ abuild cleancache; \
+ done
+ for p in $(unstable-modules) ; \
+ do \
+ cd $(rootdir)/unstable/$$p; \
+ abuild clean; \
+ abuild cleanoldpkg; \
+ abuild cleanpkg; \
+ abuild cleancache; \
+ done
+