aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-07-22 12:36:06 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-07-22 12:36:06 +0000
commitced0fad7eddb52a4c80c58cf610fcbd7defd3e9f (patch)
tree4a8c3912f71df16a0c35b38e84c033bdcd44adad /Makefile
parent80957762346bbb311d056d365053ec26552ea160 (diff)
downloadaports-ced0fad7eddb52a4c80c58cf610fcbd7defd3e9f.tar.bz2
aports-ced0fad7eddb52a4c80c58cf610fcbd7defd3e9f.tar.xz
Master Makefile: added cleanold target
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 67eb3daaec..a85a3ff569 100644
--- a/Makefile
+++ b/Makefile
@@ -16,28 +16,28 @@ non-free-pkgs := $(shell ./aport.lua deplist $(rootdir) non-free)
unstable-pkgs := $(shell ./aport.lua deplist $(rootdir) unstable)
-main:
+main:
for p in $(main-pkgs) ; \
do \
cd $(rootdir)/$@/$$p; \
abuild -r; \
done
-testing:
+testing:
for p in $(testing-pkgs) ; \
do \
cd $(rootdir)/$@/$$p; \
abuild -r; \
done
-non-free:
+non-free:
for p in $(non-free-pkgs) ; \
do \
cd $(rootdir)/$@/$$p; \
abuild -r; \
done
-unstable:
+unstable:
for p in $(unstable-pkgs) ; \
do \
cd $(rootdir)/$@/$$p; \
@@ -51,6 +51,12 @@ clean:
abuild cleanpkg; \
done
+cleanold:
+ for p in $(all-pkgs) ; do \
+ cd $(rootdir)/$$p; \
+ abuild cleanoldpkg; \
+ done
+
fetch:
for p in $(all-pkgs) ; do \
cd $(rootdir)/$$p; \