aboutsummaryrefslogtreecommitdiffstats
path: root/community/R
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-30 13:05:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-30 13:05:56 +0200
commit93da191f562ed18f03d95ddb3888be3c2a89581a (patch)
tree7bdb575e7183011ca88fd49715efeb2580e70f08 /community/R
parent10a9c544a4bd29d1129f8cfb5579ac72e01a7ae1 (diff)
downloadaports-93da191f562ed18f03d95ddb3888be3c2a89581a.tar.bz2
aports-93da191f562ed18f03d95ddb3888be3c2a89581a.tar.xz
community/R: add very basic check
Diffstat (limited to 'community/R')
-rw-r--r--community/R/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index 8c55434ea3..f594de82e7 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -56,6 +56,14 @@ build() {
make -C src/nmath/standalone
}
+# TODO: Run provided test suite.
+check() {
+ cd "$builddir"
+
+ ./bin/R --version
+ ./bin/R --slave --vanilla -e 'print("Hello, world!")'
+}
+
package() {
local destdir="$pkgdir/$_rhome"