aboutsummaryrefslogtreecommitdiffstats
path: root/community/R
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-14 21:18:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-15 14:31:22 -0300
commite2bce14c748aacb867713cb81a91fad6e8e7f7f6 (patch)
tree594985df9cd0e43ebf1c2b17c716b298c57cafbe /community/R
parent3dac51cb3f7ba8baad96762a835ddc6273caf764 (diff)
downloadaports-e2bce14c748aacb867713cb81a91fad6e8e7f7f6.tar.bz2
aports-e2bce14c748aacb867713cb81a91fad6e8e7f7f6.tar.xz
community/R: add R to R-dev depends and update install msg
Diffstat (limited to 'community/R')
-rw-r--r--community/R/APKBUILD9
-rw-r--r--community/R/R.post-install2
2 files changed, 9 insertions, 2 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index 6682cafeeb..34558fa943 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
pkgver=3.6.1
-pkgrel=0
+pkgrel=1
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
arch="all"
@@ -16,7 +16,7 @@ makedepends="$depends_dev cairo-dev libxmu-dev openjdk8-jre-base pango-dev
perl tiff-dev tk-dev
"
install="$pkgname.post-install"
-subpackages="$pkgname-mathlib $pkgname-dev $pkgname-doc"
+subpackages="$pkgname-mathlib $pkgname-dev:_dev $pkgname-doc"
source="https://cran.r-project.org/src/base/R-${pkgver%%.*}/$pkgname-$pkgver.tar.gz"
_rhome="usr/lib/R"
@@ -95,4 +95,9 @@ mathlib() {
mv "$pkgdir"/usr/lib/libRmath.so* "$subpkgdir"/usr/lib
}
+_dev() {
+ depends="R=$pkgver-r$pkgrel"
+ default_dev
+}
+
sha512sums="fae7d114437c4b5d10fcb2a4265acd707ad2a4810eeb7c11e25caca1d85093a1495c2e13457b4894c1508830ec1b2be95379b7d54007cf3e574c2a9eea28ef80 R-3.6.1.tar.gz"
diff --git a/community/R/R.post-install b/community/R/R.post-install
index f4603051e1..2f831c5159 100644
--- a/community/R/R.post-install
+++ b/community/R/R.post-install
@@ -5,4 +5,6 @@ cat <<EOF
* If you want to install R packages from CRAN that contains native extensions,
* then you must also install R-dev.
*
+* To avoid warnings about R.css when installing R extensions also install R-doc.
+*
EOF