aboutsummaryrefslogtreecommitdiffstats
path: root/community/R
diff options
context:
space:
mode:
authorMike Sullivan <mksully@us.ibm.com>2017-12-09 19:59:19 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-12-11 16:42:46 +0100
commit513fb7dbbcbe8c118f7492d11cb07d4c724f5238 (patch)
tree8529b6da78a61dbe4d73fd789b767d66f7086ae4 /community/R
parent2fecb6a0b308ed17665e84ff004502cd24b15e43 (diff)
downloadaports-513fb7dbbcbe8c118f7492d11cb07d4c724f5238.tar.bz2
aports-513fb7dbbcbe8c118f7492d11cb07d4c724f5238.tar.xz
community/R: fix build failure on ppc64le - run make with -j1
Add -j1 option to make command to avoid segfaults on cocurrent R binary invocations during build.
Diffstat (limited to 'community/R')
-rw-r--r--community/R/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index e8e8da03c4..c345e7a5b6 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -6,8 +6,7 @@ pkgver=3.4.3
pkgrel=0
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org"
-# ppc64le: segfaults in build since 3.4.3
-arch="all !s390x !ppc64le"
+arch="all !s390x"
license="GPL-2 GPL-3 LGPL-2.1"
depends="$pkgname-mathlib"
depends_dev="gcc gfortran icu-dev libjpeg-turbo libpng-dev make openblas-dev
@@ -53,8 +52,8 @@ build() {
--with-tcltk \
--with-x
- make
- make -C src/nmath/standalone
+ make -j1
+ make -j1 -C src/nmath/standalone
}
# TODO: Run provided test suite.