aboutsummaryrefslogtreecommitdiffstats
path: root/community/abduco/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-01 12:40:04 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-01 21:07:16 +0000
commitd9a7d17cd19489dbf3de9f1e0ad9e6e2accd1817 (patch)
tree9e969f3ec87c4afa46aab8bde64a3e14cebcdcf8 /community/abduco/APKBUILD
parent22f0eccac2059acd58dcee79cda279d439ee8886 (diff)
downloadaports-d9a7d17cd19489dbf3de9f1e0ad9e6e2accd1817.tar.bz2
aports-d9a7d17cd19489dbf3de9f1e0ad9e6e2accd1817.tar.xz
community/abduco: modernize
Closes GH-8364
Diffstat (limited to 'community/abduco/APKBUILD')
-rw-r--r--community/abduco/APKBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/community/abduco/APKBUILD b/community/abduco/APKBUILD
index 695ea9cf42..604e299d59 100644
--- a/community/abduco/APKBUILD
+++ b/community/abduco/APKBUILD
@@ -7,26 +7,19 @@ pkgdesc="Session management in a clean and simple way"
url="http://www.brain-dump.org/projects/abduco/"
arch="all"
license="MIT"
-depends=""
-depends_dev=""
-makedepends=""
-install=""
subpackages="$pkgname-doc"
source="http://www.brain-dump.org/projects/$pkgname/$pkgname-$pkgver.tar.gz
fix-tests.patch"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- make -C "$builddir"
+ make
}
check() {
- cd "$builddir"
./testsuite.sh
}
package() {
- cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 README.md \
"$pkgdir"/usr/share/doc/$pkgname/README.md