aboutsummaryrefslogtreecommitdiffstats
path: root/community/afl
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-06-23 19:29:34 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 14:41:04 -0300
commitff6da76883a3bf4d869ae812cd9b075085c981cc (patch)
tree7fd906321b39eca64ca857e8ff9d368ed47ab452 /community/afl
parent2fb8dd928bdd89703d98409e94a1a41fb10c1a34 (diff)
downloadaports-ff6da76883a3bf4d869ae812cd9b075085c981cc.tar.bz2
aports-ff6da76883a3bf4d869ae812cd9b075085c981cc.tar.xz
community/afl: enable armhf
Diffstat (limited to 'community/afl')
-rw-r--r--community/afl/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/community/afl/APKBUILD b/community/afl/APKBUILD
index 269dc94d3a..04f45a0262 100644
--- a/community/afl/APKBUILD
+++ b/community/afl/APKBUILD
@@ -2,26 +2,24 @@
# Maintainer: Marian <marian.buschsieweke@ovgu.de>
pkgname=afl
pkgver=2.52b
-pkgrel=1
+pkgrel=2
pkgdesc="Fuzzer relying on genetic algorithms instead of brute force"
url="http://lcamtuf.coredump.cx/afl/"
-arch="all !x86 !armhf"
+arch="all !x86"
license="Apache-2.0"
+options="!check" # no tests provided
depends="clang llvm"
makedepends="clang-dev llvm-dev"
subpackages="$pkgname-doc"
source="http://lcamtuf.coredump.cx/$pkgname/releases/$pkgname-$pkgver.tgz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
local dir; for dir in "$builddir" "$builddir"/llvm_mode; do
- make -C "$dir" PREFIX=/usr CC=clang AFL_NO_X86=1
+ make AFL_NO_X86=1 -C "$dir" PREFIX=/usr CC=clang
done
}
package() {
- cd "$builddir"
-
make AFL_NO_X86=1 PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 llvm_mode/README.llvm \
"$pkgdir"/usr/share/doc/$pkgname/README.llvm_mode