aboutsummaryrefslogtreecommitdiffstats
path: root/community/albatross-themes
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 10:35:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 10:43:10 -0300
commit7811f11a8c8e38e101d39aac6ff4babeb0cfa549 (patch)
treefd9c4f1aeb1192b9f1ebdc3a5e5bd6a7fdc47ae5 /community/albatross-themes
parent2909cdf8a3acd698b837a56112827049d049ecec (diff)
downloadaports-7811f11a8c8e38e101d39aac6ff4babeb0cfa549.tar.bz2
aports-7811f11a8c8e38e101d39aac6ff4babeb0cfa549.tar.xz
community/albatross-themes: fix url fix license
Diffstat (limited to 'community/albatross-themes')
-rw-r--r--community/albatross-themes/APKBUILD22
1 files changed, 5 insertions, 17 deletions
diff --git a/community/albatross-themes/APKBUILD b/community/albatross-themes/APKBUILD
index d597e2ce13..ce1da2a955 100644
--- a/community/albatross-themes/APKBUILD
+++ b/community/albatross-themes/APKBUILD
@@ -1,35 +1,23 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=albatross-themes
pkgver=1.7.4
-pkgrel=0
+pkgrel=1
pkgdesc="A clean minimalistic theme for Xfce, GTK 2 and 3"
-url="http://shimmerproject.org/project/albatross/"
+url="https://github.com/shimmerproject/Albatross"
arch="noarch"
-license="GPL-2.0 or CC-BY-SA"
-makedepends="$depends_dev"
+license="GPL-2.0-or-later OR CC-BY-SA-3.0"
subpackages="$pkgname-gtk2 $pkgname-gtk3 $pkgname-metacity $pkgname-xfwm4"
source="albatross-$pkgver.tar.gz::https://github.com/shimmerproject/Albatross/archive/v$pkgver.tar.gz"
-_builddir="$srcdir"/Albatross-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/Albatross-$pkgver
build() {
- cd "$_builddir"
# Remove Unity theme
rm -f gtk-3.0/apps/unity.css
sed -i '/unity\.css/d' gtk-3.0/gtk.css
}
package() {
- cd "$_builddir"
mkdir -p "$pkgdir"/usr/share/themes/Albatross
cp -pr * "$pkgdir"/usr/share/themes/Albatross
}
@@ -44,7 +32,7 @@ _mv() {
for _i; do
msg "moving $_i"
mv "$pkgdir"/usr/share/themes/Albatross/$_i \
- "$subpkgdir"/usr/share/themes/Albatross || return 1
+ "$subpkgdir"/usr/share/themes/Albatross
done
}