aboutsummaryrefslogtreecommitdiffstats
path: root/community/alsa-tools
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-29 22:54:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-29 22:54:35 -0300
commitf77cf815be9045a7c82728821b64512fdf1cdaca (patch)
tree39ec7901e3e1087f97e5527e1d74f9909302985a /community/alsa-tools
parent71f076e558696b1511a0f21c5830c07bfab86338 (diff)
downloadaports-f77cf815be9045a7c82728821b64512fdf1cdaca.tar.bz2
aports-f77cf815be9045a7c82728821b64512fdf1cdaca.tar.xz
community/alsa-tools: move from testing
Diffstat (limited to 'community/alsa-tools')
-rw-r--r--community/alsa-tools/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/alsa-tools/APKBUILD b/community/alsa-tools/APKBUILD
new file mode 100644
index 0000000000..ce2b1696f8
--- /dev/null
+++ b/community/alsa-tools/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=alsa-tools
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="Advanced tools for certain sound cards"
+url="https://www.alsa-project.org"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="fltk-dev gtk+2.0-dev gtk+3.0-dev alsa-lib-dev bash autoconf automake
+ libtool"
+options="!check" # No tests
+subpackages="$pkgname-dev $pkgname-doc $pkgname-gui:_gui"
+source="ftp://ftp.alsa-project.org/pub/tools/alsa-tools-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+ # Remove qlo10k1 package, only works with Qt2/Qt3
+ sed 's/qlo10k1//' -i Makefile
+}
+
+build() {
+ make configure CONFIGURE_ARGS="--prefix=/usr"
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+
+ cp -r "$pkgdir"/usr/local/* "$pkgdir"/usr/
+ rm -r "$pkgdir"/usr/local
+}
+
+_gui() {
+ pkgdesc="$pkgdesc (GUI tools)"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/echomixer "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/envy24control "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/hdajackretask "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/hdspconf "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/hdspmixer "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/rmedigicontrol "$subpkgdir"/usr/bin
+}
+
+sha512sums="935d46ee3cc843566ccea183bcf7ea36439a4a6aa22964ebf6fd2722b78ec634d3be4e6a30b04c608abe6c5a132dd633f8343fff19f9d90a756d6699fc849a16 alsa-tools-1.2.2.tar.bz2"