aboutsummaryrefslogtreecommitdiffstats
path: root/community/anytun
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-27 02:00:24 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-28 13:11:26 +0000
commitbbdc6eb8430581f107bc23e05559eb485a8fc154 (patch)
tree0a8ddf10b9ec70139db2f18391741066b48d6f41 /community/anytun
parent55c22575d57e17c72f708ebc7e58d7370924fb56 (diff)
downloadaports-bbdc6eb8430581f107bc23e05559eb485a8fc154.tar.bz2
aports-bbdc6eb8430581f107bc23e05559eb485a8fc154.tar.xz
main/boost: bump dependent aports
Diffstat (limited to 'community/anytun')
-rw-r--r--community/anytun/APKBUILD14
-rw-r--r--community/anytun/fix-iostream.patch10
-rw-r--r--community/anytun/fix-werror-compile-flags.patch2
3 files changed, 15 insertions, 11 deletions
diff --git a/community/anytun/APKBUILD b/community/anytun/APKBUILD
index b7c7b95040..684cca0201 100644
--- a/community/anytun/APKBUILD
+++ b/community/anytun/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=anytun
pkgver=0.3.6
-pkgrel=4
+pkgrel=5
pkgdesc="Secure anycast tunneling protocol implementation for flexible and fault-tolerant VPNs"
url="http://www.anytun.org"
arch="all"
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-doc"
source="http://www.anytun.org/download/$pkgname-$pkgver.tar.gz
boost-mt.patch
fix-werror-compile-flags.patch
+ fix-iostream.patch
$pkgname.initd"
_builddir="$srcdir"/$pkgname-$pkgver/src
@@ -47,15 +48,8 @@ package() {
install -Dm 755 "$srcdir"/$pkgname.initd "${pkgdir}"/etc/init.d/$pkgname
}
-md5sums="90683b03a3f438639c5f2de0730dcf5e anytun-0.3.6.tar.gz
-d7220eae296c814ee100d8ca1f5cf19a boost-mt.patch
-3122d09abb4d8f24043e11bdbf5b8229 fix-werror-compile-flags.patch
-d429ba9feaaf15bb268b811eccc71862 anytun.initd"
-sha256sums="afef9ba3002df9d1bd2eba2ec2ab9a9551a0822bfa9664bfbc3c97a6e2e313a8 anytun-0.3.6.tar.gz
-31dca9b29da41ed338d12ff96171b1f2a84013f689af0965c2d97f2fbcf0b499 boost-mt.patch
-a07966d0866dc18b88682fffa3892535ed6422cb1200c7bdbeec2a019a8a34b4 fix-werror-compile-flags.patch
-f2390be3b27d2a208e4d77bf776d62c2dd9a92a79a30e5394188b82af6f55037 anytun.initd"
sha512sums="470bec0ed96fd8cd7921d8a110272578020b666e8852c9e52a88da9957b2d641cd2b43cc8c9e453331a9f848282ea4516e304d71add6fea71a7ce3e6d76117b1 anytun-0.3.6.tar.gz
e19522a26529bb16591ed724d499c3b7fd7060e937eadc93f7719c29aaa604b953c59b94024efe2227331741ba5bbde084619dd42071cf086ef803906e6678a7 boost-mt.patch
-f9705cf1879a8f50bc53fae04b48a88baa9aa5f7f1035b0ec737bdacaa21007da76b8985e1b9cba05936c9dc94200cb3c4ff39492755c8f219e42ee73ecf1431 fix-werror-compile-flags.patch
+e2f23ed7183f7636716946458b108a7055beb190a89d462d815d164f61a5c52b268620f053e5bb169c48d4e9cd56ad2f1d3d65a23a202375ef13998c29f4fdf6 fix-werror-compile-flags.patch
+4d1115733f8d3d467bdd6348df451dfb60bff45685406792514717d27a567e323f76b12b4406a6d784f20716c08b596d6c09842c60e81c67fdaf8b0eed9b7530 fix-iostream.patch
a31455058e0ac60ed9457c79eea789ce19ba49abc200b59c0d8390eb0c3b6f09813177f9b679fb8ac69ac7b0be862e4604d19298ae4cd79925511fff3963e93d anytun.initd"
diff --git a/community/anytun/fix-iostream.patch b/community/anytun/fix-iostream.patch
new file mode 100644
index 0000000000..12dffd8d6d
--- /dev/null
+++ b/community/anytun/fix-iostream.patch
@@ -0,0 +1,10 @@
+--- a/src/routingTreeNode.cpp.orig 2018-03-27 19:30:45.345569478 +0300
++++ b/src/routingTreeNode.cpp 2018-03-27 19:30:53.217662424 +0300
+@@ -44,6 +44,7 @@
+ */
+
+ #include "routingTreeNode.h"
++#include <iostream>
+
+ RoutingTreeNode::RoutingTreeNode():mux_(0),valid_(false)
+ {
diff --git a/community/anytun/fix-werror-compile-flags.patch b/community/anytun/fix-werror-compile-flags.patch
index 919a74b24e..5720a7d115 100644
--- a/community/anytun/fix-werror-compile-flags.patch
+++ b/community/anytun/fix-werror-compile-flags.patch
@@ -8,7 +8,7 @@ index 65a0c74..357628e 100755
if [ $USE_CLANG -eq 0 ]; then
- CXXFLAGS='-g -Wall -Werror -Wno-error=unused-variable -O2'
- LDFLAGS='-g -Wall -Werror -O2'
-+ CXXFLAGS='-g -Wall -Wno-error=unused-variable -O2'
++ CXXFLAGS='-g -Wall -Wno-error=unused-variable -O2 -DBOOST_SYSTEM_ENABLE_DEPRECATED'
+ LDFLAGS='-g -Wall -O2'
COMPILER='g++'
else