aboutsummaryrefslogtreecommitdiffstats
path: root/community/apenwarr-redo
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-10-25 20:19:32 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-26 18:51:18 +0000
commit6452acb5c3736e77e98ef00b0fe4016c73c10f44 (patch)
tree008eba7f3f9d73666a46d6981bc9c0b2d45f4cee /community/apenwarr-redo
parentb62c984fdee9b63ebb9089a645f7eaef65f41314 (diff)
downloadaports-6452acb5c3736e77e98ef00b0fe4016c73c10f44.tar.bz2
aports-6452acb5c3736e77e98ef00b0fe4016c73c10f44.tar.xz
community/apenwarr-redo: rename from redo
There are multiple redo implementations. Rename this to indicate the origin.
Diffstat (limited to 'community/apenwarr-redo')
-rw-r--r--community/apenwarr-redo/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/apenwarr-redo/APKBUILD b/community/apenwarr-redo/APKBUILD
new file mode 100644
index 0000000000..024ad9e03b
--- /dev/null
+++ b/community/apenwarr-redo/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=redo
+pkgver=0.42
+pkgrel=0
+pkgdesc="Smaller, easier, more powerful, and more reliable than make"
+url="https://redo.readthedocs.io/en/latest/"
+arch="noarch"
+license="Apache-2.0"
+depends="python2"
+makedepends="perl"
+checkdepends="cpio"
+subpackages="$pkgname-doc"
+source="https://github.com/apenwarr/redo/archive/redo-${pkgver}.tar.gz"
+
+builddir="$srcdir/redo-redo-${pkgver}"
+
+build() {
+ ./do build
+}
+
+check() {
+ # Causes issues with the test suite
+ unset CC CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
+ ./do test
+}
+
+package() {
+ DESTDIR="$pkgdir" PREFIX="/usr" ./do install
+}
+
+cleanup_srcdir() {
+ # Test suite changes some files to read-only, resulting in errors on
+ # cleanup.
+ [ -e "$srcdir" ] && chmod -R a+w "$srcdir"
+
+ default_cleanup_srcdir
+}
+
+sha512sums="41b8417136f98d12edf3c62f027f2459ae3fb92f6c5464553d79c3a52344de57220a5c64b565118da0a99c1544eaa153a468ffcdcfbf7193c76c896bcd40e900 redo-0.42.tar.gz"