aboutsummaryrefslogtreecommitdiffstats
path: root/community/apk-gtk3/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-25 01:17:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 06:48:46 -0300
commit1147293c2b0537d0ba6566b2251483a05a97da18 (patch)
treec5b1026b7bd86047a6ce5173ff901edd5bc20450 /community/apk-gtk3/APKBUILD
parent5fb7956a67b3d1760f3601e1d88ce54e16ecdbe4 (diff)
downloadaports-1147293c2b0537d0ba6566b2251483a05a97da18.tar.bz2
aports-1147293c2b0537d0ba6566b2251483a05a97da18.tar.xz
community/apk-gtk3: rename from apk-gtk
Diffstat (limited to 'community/apk-gtk3/APKBUILD')
-rw-r--r--community/apk-gtk3/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/apk-gtk3/APKBUILD b/community/apk-gtk3/APKBUILD
new file mode 100644
index 0000000000..295c850353
--- /dev/null
+++ b/community/apk-gtk3/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer:
+pkgname=apk-gtk
+pkgver=0.1
+pkgrel=1
+pkgdesc="gtk+ frontend to apk"
+url="https://github.com/kaniini/apk-gtk"
+arch="all"
+license="MIT"
+makedepends="gtk+2.0-dev gtk+3.0-dev vte-dev vte3-dev"
+subpackages="$pkgname-gtk3 $pkgname-policy::noarch"
+source="apk-gtk-$pkgver.tar.gz::https://github.com/kaniini/apk-gtk/archive/v$pkgver.tar.gz"
+options="!check"
+
+build() {
+ make GTK_VERSION=3
+ cp apk-gtk apk-gtk.3
+
+ make clean
+ make GTK_VERSION=2
+}
+
+package() {
+ depends="$pkgname-policy"
+ make GTK_VERSION=2 DESTDIR="$pkgdir" install
+}
+
+policy() {
+ depends=""
+ pkgdesc="gtk+ frontend to apk (policykit policy)"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/polkit-1 "$subpkgdir"/usr/share/polkit-1
+}
+
+gtk3() {
+ # we can only have one or the other :/
+ depends="$pkgname-policy"
+ conflicts="$pkgname"
+
+ install -Dm755 "$builddir"/apk-gtk.3 "$subpkgdir"/usr/sbin/apk-gtk
+ install -Dm644 "$builddir"/apk-gtk.svg "$subpkgdir"/usr/share/apk-gtk/apk-gtk.svg
+}
+
+sha512sums="1e620f53f759d4c73edf66505fa17d9034edbe99f75764ba0e3cf75dd292451dd53784f1150cc6c6021e5b2a6e92a0f3cade75b32e6930207b9e60306606561e apk-gtk-0.1.tar.gz"