aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-04 12:29:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-04 13:15:59 -0300
commitf6aa0699270d405e30b1f77659857c52422c30b7 (patch)
treeeb20413d867e99fc39aa900f0ea803d7ae3de0ed /community/appstream
parent73c913aeaab967104a094565b176bb653d2c90f7 (diff)
downloadaports-f6aa0699270d405e30b1f77659857c52422c30b7.tar.bz2
aports-f6aa0699270d405e30b1f77659857c52422c30b7.tar.xz
community/appstream: move from testing
Diffstat (limited to 'community/appstream')
-rw-r--r--community/appstream/APKBUILD52
-rw-r--r--community/appstream/appstream.post-install6
-rw-r--r--community/appstream/appstream.post-upgrade6
-rw-r--r--community/appstream/appstream.trigger4
4 files changed, 68 insertions, 0 deletions
diff --git a/community/appstream/APKBUILD b/community/appstream/APKBUILD
new file mode 100644
index 0000000000..298fe73a64
--- /dev/null
+++ b/community/appstream/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=appstream
+pkgver=0.12.8
+pkgrel=0
+pkgdesc="Provides a standard for creating app stores across distributions"
+url="https://distributions.freedesktop.org/wiki/AppStream"
+arch="all"
+license="LGPL-2.1-or-later AND GPL-2.0-or-later"
+makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection-dev
+ gperf qt5-qtbase-dev"
+triggers="$pkgname.trigger=/usr/share/app-info/*"
+install="$pkgname.post-install $pkgname.post-upgrade"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-lang"
+source="https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz"
+builddir="$srcdir/AppStream-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dqt=true \
+ -Ddocs=false \
+ -Dapidocs=false \
+ -Dinstall-docs=false \
+ -Dstemming=false \
+ -Dvapi=false \
+ -Dapt-support=false \
+ -Dgir=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+qt() {
+ pkgdesc="Qt5 interface for AppStream"
+ license="LGPL-2.1-or-later"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libAppStreamQt.so.* "$subpkgdir"/usr/lib
+}
+sha512sums="4354ef1840d919102647feffc38687f508b14fe9c047c868448347d888aa821dd8a4d25787a2ffb55247f8e9e20e9e03ba330ad74ad61d476be0c414c04a7c30 AppStream-0.12.8.tar.xz"
diff --git a/community/appstream/appstream.post-install b/community/appstream/appstream.post-install
new file mode 100644
index 0000000000..5a63845bb8
--- /dev/null
+++ b/community/appstream/appstream.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force
+
+exit 0
diff --git a/community/appstream/appstream.post-upgrade b/community/appstream/appstream.post-upgrade
new file mode 100644
index 0000000000..5a63845bb8
--- /dev/null
+++ b/community/appstream/appstream.post-upgrade
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force
+
+exit 0
diff --git a/community/appstream/appstream.trigger b/community/appstream/appstream.trigger
new file mode 100644
index 0000000000..51f6d89acd
--- /dev/null
+++ b/community/appstream/appstream.trigger
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+umask 022
+/usr/bin/appstreamcli refresh-cache --force