aboutsummaryrefslogtreecommitdiffstats
path: root/community/asciinema
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-06-27 10:17:05 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-07-04 11:42:28 +0200
commit2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd (patch)
tree97c60fb3221dfe78cd7ccfda5db6125c81d5f676 /community/asciinema
parent00e8ff605f1c4f6386596f35f2a5287ff9b8bc55 (diff)
downloadaports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.bz2
aports-2ff62bbb9f7b2c82a826d7b159c1bc482aa8f0bd.tar.xz
testing/[various]: move packages to community
Moves the packages listed below from the testing to the community repository after successfully testing of said packages. asciinema at calcurse cmus compton cpio dvd+rw-tools fortune fvwm geary h2o heirloom-mailx leafpad nedit nmh rover tor torsocks urlview vdesk w3m wbar xcalc xclock xeyes xkill
Diffstat (limited to 'community/asciinema')
-rw-r--r--community/asciinema/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/asciinema/APKBUILD b/community/asciinema/APKBUILD
new file mode 100644
index 0000000000..1da4dcaaa1
--- /dev/null
+++ b/community/asciinema/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=asciinema
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A Command line recorder for asciinema.org service"
+url="https://github.com/asciinema/asciinema/"
+arch="all"
+license="GPLv3"
+depends="curl"
+depends_dev=""
+makedepends="go python"
+subpackages="$pkgname-doc"
+options="!strip"
+source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export GOPATH="$_builddir"
+ mkdir -p src/github.com/asciinema
+ ln -s "$_builddir" src/github.com/asciinema/asciinema
+ make build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ PREFIX="$pkgdir"/usr make install || return 1
+}
+
+md5sums="f61680ca17328ed43b61a24b1c267e29 asciinema-1.2.0.tar.gz"
+sha256sums="64b8c2b034945a99398c5593fd8831c6448fd3b6dd788a979582805bfdcb5746 asciinema-1.2.0.tar.gz"
+sha512sums="b172fa2c122ce6d4191d898292f70b462f18c9436a7a95b56a3d4405f66a4003d52877b5d632a829f94704f7d8a07c1202f1d3059e1eec6b583b63daf90a9006 asciinema-1.2.0.tar.gz"