aboutsummaryrefslogtreecommitdiffstats
path: root/community/aspcud
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 14:15:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 14:53:00 -0300
commit01b00d68542b961d25b4deb1c32a4183daa183b5 (patch)
treeb045124d8de1acadf83ea34b293ad279f73c7f8f /community/aspcud
parent41f5158548659f6549e2040a15bd023cd12d0d7c (diff)
downloadaports-01b00d68542b961d25b4deb1c32a4183daa183b5.tar.bz2
aports-01b00d68542b961d25b4deb1c32a4183daa183b5.tar.xz
community/aspcud: modernize
Diffstat (limited to 'community/aspcud')
-rw-r--r--community/aspcud/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/aspcud/APKBUILD b/community/aspcud/APKBUILD
index f399559647..3eb8587483 100644
--- a/community/aspcud/APKBUILD
+++ b/community/aspcud/APKBUILD
@@ -2,29 +2,27 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=aspcud
pkgver=1.9.4
-pkgrel=2
+pkgrel=3
pkgdesc="Package dependency solver"
url="https://potassco.org/aspcud/"
arch="all"
license="MIT"
depends="boost gringo clasp"
makedepends="boost-dev cmake re2c"
-install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/potassco/aspcud/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- mkdir build
- cd build
- cmake .. -DGRINGO_LOC=/usr/bin/gringo -DCLASP_LOC=/usr/bin/clasp -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DGRINGO_LOC=/usr/bin/gringo \
+ -DCLASP_LOC=/usr/bin/clasp \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
}
package() {
- cd "${builddir}/build"
- make DESTDIR="${pkgdir}" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="6bb04fca0d5df1bfc2d34974386899821790154e10e988dfd34ceada005970ac8dd0bec560b35e20195aa529ac7f73baa07c7d81d9744127e57afece04b2e574 aspcud-1.9.4.tar.gz"