aboutsummaryrefslogtreecommitdiffstats
path: root/community/atkmm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 05:40:30 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 15:55:31 +0000
commitd7f6bb28d8f75f6ea79c8a5def3ef3e2511f12e9 (patch)
treefca8ee788b5fc0d7b9cc12aedf2a40b69637d662 /community/atkmm
parentac49c667cb9f169015d077548611846dba647b8c (diff)
downloadaports-d7f6bb28d8f75f6ea79c8a5def3ef3e2511f12e9.tar.bz2
aports-d7f6bb28d8f75f6ea79c8a5def3ef3e2511f12e9.tar.xz
community/atkmm: move from main
Diffstat (limited to 'community/atkmm')
-rw-r--r--community/atkmm/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/atkmm/APKBUILD b/community/atkmm/APKBUILD
new file mode 100644
index 0000000000..b95be67198
--- /dev/null
+++ b/community/atkmm/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=atkmm
+pkgver=2.28.0
+pkgrel=1
+pkgdesc="C++ bindings for atk"
+options="!check" # No testsuite
+url="https://www.gtkmm.org/en/"
+arch="all"
+license="LGPL-2.0-or-later"
+makedepends="atk-dev glibmm-dev libsigc++-dev perl"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/atkmm/${pkgver%.*}/atkmm-$pkgver.tar.xz"
+
+replaces="gtkmm"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="8457cff58648c3d3944d6a9fb400062985c70a714856a5d84d4553cb6b1202bdc47aa48c612851fea1cc1b7ab59381116c65d2a22212907e3c4b7090601946bc atkmm-2.28.0.tar.xz"