aboutsummaryrefslogtreecommitdiffstats
path: root/community/attica
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-04-05 08:50:14 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-04-06 17:19:56 +0000
commitabf5a576b646c92413536c7c731474c6f212377f (patch)
tree2313210542d44a7392f6df615c703c7bd17895af /community/attica
parente664c4baadef1d2ab6612112444a0f470ee67491 (diff)
downloadaports-abf5a576b646c92413536c7c731474c6f212377f.tar.bz2
aports-abf5a576b646c92413536c7c731474c6f212377f.tar.xz
community/attica: upgrade to 5.56.0
Diffstat (limited to 'community/attica')
-rw-r--r--community/attica/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/attica/APKBUILD b/community/attica/APKBUILD
index 13d2a4af10..b98abf53a8 100644
--- a/community/attica/APKBUILD
+++ b/community/attica/APKBUILD
@@ -1,17 +1,17 @@
# Contributor:
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=attica
-pkgver=0.4.2
+pkgver=5.56.0
pkgrel=0
pkgdesc="Freedesktop OCS binding for Qt"
url="http://www.kde.org/"
arch="all"
license="LGPL-2.0-or-later"
-makedepends="qt-dev cmake automoc4"
+makedepends="qt5-qttools-dev extra-cmake-modules cmake automoc4"
subpackages="$pkgname-dev"
-source="http://download.kde.org/stable/attica/attica-$pkgver.tar.bz2"
-
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
+
prepare() {
default_prepare
mkdir -p "$builddir"/build
@@ -19,17 +19,23 @@ prepare() {
build() {
cd "$builddir"/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DQT4_BUILD=ON \
- -Wno-dev \
- "$builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -Wno-dev \
+ "$builddir"
make
}
+check() {
+ cd "$builddir"/build
+ make test
+}
+
package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install
}
-sha512sums="cef5d5c4bf01ed45ed8b59db354a4ac7949de435a45e4f753c847cadc15855e25997dedf1ff20c7bc4a2724d2cdba15139c54f0682df7d8cc8750de5be6f716e attica-0.4.2.tar.bz2"
+sha512sums="e365aeeec6545406e03350494601b23f0b5bebcc978ca3c23327007124037a68476127e94438462898c3cdb9df3c816efb04bdd11a3cdbc322437626ae63e2cc attica-5.56.0.tar.xz"