aboutsummaryrefslogtreecommitdiffstats
path: root/community/autoconf2.13
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 13:49:35 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-01-28 13:49:35 -0600
commit7a1bdf05a3bc11e3d0e1e8778de29827eed31428 (patch)
tree9ae69d3674b75b25e13997d625b2bbe86ad45aca /community/autoconf2.13
parentb5b2b5a7d6a68565db720aed85aaf0a5135fc4da (diff)
downloadaports-7a1bdf05a3bc11e3d0e1e8778de29827eed31428.tar.bz2
aports-7a1bdf05a3bc11e3d0e1e8778de29827eed31428.tar.xz
community/autoconf2.13: fix test suite and add check
Diffstat (limited to 'community/autoconf2.13')
-rw-r--r--community/autoconf2.13/APKBUILD32
-rw-r--r--community/autoconf2.13/getloadavg.patch36
2 files changed, 53 insertions, 15 deletions
diff --git a/community/autoconf2.13/APKBUILD b/community/autoconf2.13/APKBUILD
index 443b409c01..67d2f50018 100644
--- a/community/autoconf2.13/APKBUILD
+++ b/community/autoconf2.13/APKBUILD
@@ -1,40 +1,42 @@
# Maintainer:
pkgname=autoconf2.13
pkgver=2.13
-pkgrel=0
+pkgrel=1
pkgdesc="A GNU tool for automatically configuring source code"
arch="noarch"
license="GPL-2.0"
url="https://www.gnu.org/software/autoconf"
depends="m4 perl"
+checkdepends="dejagnu gfortran"
source="ftp://ftp.gnu.org/pub/gnu/autoconf/autoconf-${pkgver}.tar.gz
+ getloadavg.patch
"
subpackages="$pkgname-doc"
-_builddir="${srcdir}/autoconf-${pkgver}"
+builddir="$srcdir"/autoconf-$pkgver
prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- esac
- done
+ default_prepare
+ update_config_sub # Required for AC_F77_LIBRARY_LDFLAGS
}
build() {
- cd "$_builddir"
+ cd "$builddir"
M4=/usr/bin/m4 ./configure --prefix=/usr --program-suffix=-2.13
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ F77=gfortran make check
}
package() {
- cd "$_builddir"
- make prefix="${pkgdir}/usr" infodir="${pkgdir}/usr/share/info" install || return 1
+ cd "$builddir"
+ make prefix="$pkgdir/usr" infodir="$pkgdir/usr/share/info" install
rm -f "$pkgdir"/usr/share/info/dir
rm -f "$pkgdir"/usr/share/info/standards.info
}
-sha512sums="602584f4c77b7a554aaa068eda5409b68eb0b3229e9c224bffb91c83c4314d25de15bd560a323626ff78f6df339c79e1ef8938c54b78ecadf4dc75c5241290ad autoconf-2.13.tar.gz"
+sha512sums="602584f4c77b7a554aaa068eda5409b68eb0b3229e9c224bffb91c83c4314d25de15bd560a323626ff78f6df339c79e1ef8938c54b78ecadf4dc75c5241290ad autoconf-2.13.tar.gz
+483d0ba23c90e41c746868ea57436033930906f306b86de5e23284a60da069f4203d478615d653b8acee7226d9b02427be42a9764ff82710019de485e5f26d1b getloadavg.patch"
diff --git a/community/autoconf2.13/getloadavg.patch b/community/autoconf2.13/getloadavg.patch
new file mode 100644
index 0000000000..46f26d692f
--- /dev/null
+++ b/community/autoconf2.13/getloadavg.patch
@@ -0,0 +1,36 @@
+From debian/patches/other-debian.patch.
+
+autoconf (2.13-24) unstable; urgency=low
+ * Fix test for getloadavg (Bug#84170).
+ -- Ben Pfaff <blp@gnu.org> Wed, 31 Jan 2001 19:12:03 -0500
+
+--- autoconf-2.13/acspecific.m4
++++ autoconf-2.13/acspecific.m4
+@@ -1477,14 +1477,19 @@ AC_SUBST(ALLOCA)dnl
+ AC_DEFUN(AC_FUNC_GETLOADAVG,
+ [ac_have_func=no # yes means we've found a way to get the load average.
+
+-# Some systems with -lutil have (and need) -lkvm as well, some do not.
+-# On Solaris, -lkvm requires nlist from -lelf, so check that first
+-# to get the right answer into the cache.
+-AC_CHECK_LIB(elf, elf_begin, LIBS="-lelf $LIBS")
+-AC_CHECK_LIB(kvm, kvm_open, LIBS="-lkvm $LIBS")
+-# Check for the 4.4BSD definition of getloadavg.
+-AC_CHECK_LIB(util, getloadavg,
+- [LIBS="-lutil $LIBS" ac_have_func=yes ac_cv_func_getloadavg_setgid=yes])
++# Some systems have getloadavg without any extra libraries.
++AC_CHECK_FUNC(getloadavg, [ac_have_func=yes])
++
++if test $ac_have_func = no; then
++ # Some systems with -lutil have (and need) -lkvm as well, some do not.
++ # On Solaris, -lkvm requires nlist from -lelf, so check that first
++ # to get the right answer into the cache.
++ AC_CHECK_LIB(elf, elf_begin, LIBS="-lelf $LIBS")
++ AC_CHECK_LIB(kvm, kvm_open, LIBS="-lkvm $LIBS")
++ # Check for the 4.4BSD definition of getloadavg.
++ AC_CHECK_LIB(util, getloadavg,
++ [LIBS="-lutil $LIBS" ac_have_func=yes ac_cv_func_getloadavg_setgid=yes])
++fi
+
+ if test $ac_have_func = no; then
+ # There is a commonly available library for RS/6000 AIX.