aboutsummaryrefslogtreecommitdiffstats
path: root/community/avr-libc
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-02-11 13:18:22 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-03-06 07:22:57 +0000
commit85792423e23a807ae2b3d851d44b3df5bbe515a7 (patch)
treea1f4bdc7e4817dcff71b16ce5af109feb942ad3d /community/avr-libc
parentfebea89ad2d2201548b974b1a68f5d00ef333702 (diff)
downloadaports-85792423e23a807ae2b3d851d44b3df5bbe515a7.tar.bz2
aports-85792423e23a807ae2b3d851d44b3df5bbe515a7.tar.xz
community/avr-libc: fix build on mips*, modernize
./config.guess has no exec permission so run it directly as a shell script to fix build system detection on mips*. Also remove bash from makedepends, it is not needed.
Diffstat (limited to 'community/avr-libc')
-rw-r--r--community/avr-libc/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/community/avr-libc/APKBUILD b/community/avr-libc/APKBUILD
index 747245c81c..826c06fcdc 100644
--- a/community/avr-libc/APKBUILD
+++ b/community/avr-libc/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=avr-libc
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="The C runtime library for the AVR family of microcontrollers"
url="http://savannah.nongnu.org/projects/avr-libc/"
depends="gcc-avr"
-makedepends="autoconf automake bash"
+makedepends="autoconf automake"
arch="all"
license="BSD"
subpackages="$pkgname-doc"
@@ -15,23 +15,23 @@ source="https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
- update_config_guess || return 1
+ default_prepare
+ update_config_guess
}
build() {
cd "$builddir"
- ./bootstrap || return 1
+ ./bootstrap
CC=avr-gcc ./configure \
- --build="$(./config.guess)" \
+ --build="$(/bin/sh config.guess)" \
--host=avr \
- --prefix=/usr || return 1
+ --prefix=/usr
make
}
package() {
cd "$builddir"
- make install DESTDIR="$pkgdir" || return 1
+ make install DESTDIR="$pkgdir"
if [ -d "$pkgdir"/usr/lib64 ]; then
mv "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib/
rmdir "$pkgdir"/usr/lib64