aboutsummaryrefslogtreecommitdiffstats
path: root/community/aws-cli
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-04-11 14:25:18 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-04-11 20:18:58 +0000
commit2f3bf8c62762b2911ba71a6d2a735f65900983a9 (patch)
tree15778e74218beb1fc66322d84d42f6097152fb1c /community/aws-cli
parent5476202af29c1cb76028aecf5d7ec9cd6afee687 (diff)
downloadaports-2f3bf8c62762b2911ba71a6d2a735f65900983a9.tar.bz2
aports-2f3bf8c62762b2911ba71a6d2a735f65900983a9.tar.xz
community/aws-cli: upgrade to 1.18.39
Change syntax so that linting passes. Tested manually by (1) installing the relevant packages and start bash and (2) trying out completion in bash. 1: sudo apk add bash bash-completion aws-cli && bash Test: . /etc/profile.d/bash_completion.sh complete -C '/usr/bin/aws_completer' aws Then typing `aws bu<Tab>` → `aws budgets`
Diffstat (limited to 'community/aws-cli')
-rw-r--r--community/aws-cli/APKBUILD29
1 files changed, 17 insertions, 12 deletions
diff --git a/community/aws-cli/APKBUILD b/community/aws-cli/APKBUILD
index d8c9dc496b..3248848854 100644
--- a/community/aws-cli/APKBUILD
+++ b/community/aws-cli/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=aws-cli
-pkgver=1.17.10
+pkgver=1.18.39
pkgrel=0
pkgdesc="Universal Command Line Interface for Amazon Web Services"
url="https://github.com/aws/aws-cli"
@@ -28,8 +28,9 @@ check() {
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
- rm -fr "$pkgdir"/usr/bin/aws.cmd \
- $(find "$pkgdir" -name "*.egg-info")
+ cd "$pkgdir"
+ rm -fr usr/bin/aws.cmd \
+ usr/lib/python*/site-packages/awscli-*-py*.egg-info
}
bashcomp() {
@@ -54,18 +55,22 @@ completer() {
depends=""
pkgdesc="$pkgdesc (completions helper)"
cd "$pkgdir"
- local file; for file in $(find . -name "*completer*"); do
- echo $(dirname $file)
- mkdir -p "$subpkgdir"/$(dirname $file)
- mv "$pkgdir"/$file "$subpkgdir"/$file
+ for i in \
+ usr/bin/aws_completer \
+ usr/lib/python*/site-packages/awscli/completer.py \
+ usr/lib/python*/site-packages/awscli/__pycache__/completer.cpython-*.pyc \
+ ; do
+ install -D "$i" "$subpkgdir/$i"
+ rm "$i"
done
}
doc() {
default_doc
- local path=$(python3 -c "import sys;print(sys.path[-1])")/awscli
- mkdir -p "$subpkgdir"/$path
- mv "$pkgdir"/$path/examples "$pkgdir"/$path/topics \
- "$subpkgdir"/$path/
+ local path
+ path="$(python3 -c 'import sys;print(sys.path[-1])')/awscli"
+ mkdir -p "$subpkgdir/$path"
+ mv "$pkgdir/$path/examples" "$pkgdir/$path/topics" \
+ "$subpkgdir/$path/"
}
-sha512sums="8c8c0cd03f1916b2780b35380c60b748162c759da9346b379c13f4ff5afbacb6d95d3ffebe8fe4929fb601c5c5fe416fc6d296ca71c034162b3042525af8e87f aws-cli-1.17.10.tar.gz"
+sha512sums="3defed276c9db4fee087cadb32473f8c3c8368f3d60b1429761ebb8f9e134bcf8b88edb43dc347d38a2c6a92216d27d9e407f86d7c66971fa188b5ccecc5f21e aws-cli-1.18.39.tar.gz"