aboutsummaryrefslogtreecommitdiffstats
path: root/community/bcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-10-03 14:34:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-04 14:16:35 +0000
commitbc331fde131b1e62e12a08776ca56e14411abc64 (patch)
treeb49e299c210cb7a8f5acf58a4e045936163936ab /community/bcc
parent6624c44a5bd2f64e0aa3ad50495b4dc77adc11e6 (diff)
downloadaports-bc331fde131b1e62e12a08776ca56e14411abc64.tar.bz2
aports-bc331fde131b1e62e12a08776ca56e14411abc64.tar.xz
community/bcc: fix version in .pc
Diffstat (limited to 'community/bcc')
-rw-r--r--community/bcc/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/bcc/APKBUILD b/community/bcc/APKBUILD
index 3549f260b4..81ec450073 100644
--- a/community/bcc/APKBUILD
+++ b/community/bcc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=bcc
pkgver=0.10.0
-pkgrel=4
+pkgrel=5
pkgdesc="A toolkit for creating efficient kernel tracing and manipulation programs"
url="https://github.com/iovisor/bcc/"
arch="aarch64 x86 x86_64"
@@ -26,7 +26,11 @@ prepare() {
build() {
mkdir -p "$builddir/build"
cd "$builddir/build"
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib -DPYTHON_CMD=python3 ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DPYTHON_CMD=python3 \
+ -DREVISION=$pkgver \
+ ..
make
}