aboutsummaryrefslogtreecommitdiffstats
path: root/community/bcc
diff options
context:
space:
mode:
authorAdam Jensen <acjensen@gmail.com>2019-10-06 07:42:30 -0400
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 14:42:46 +0200
commitaee8405c7da1a99988768ce4e15a57bfd5741d64 (patch)
tree45ea580795d0ae1c83e789afd5bc7a7a5e7c5161 /community/bcc
parentca375215304315ecdacf09322e7ed8588d66ed06 (diff)
downloadaports-aee8405c7da1a99988768ce4e15a57bfd5741d64.tar.bz2
aports-aee8405c7da1a99988768ce4e15a57bfd5741d64.tar.xz
community/bcc: update to 0.11.0
Diffstat (limited to 'community/bcc')
-rw-r--r--community/bcc/10-use-system-libbpf.patch23
-rw-r--r--community/bcc/APKBUILD10
2 files changed, 23 insertions, 10 deletions
diff --git a/community/bcc/10-use-system-libbpf.patch b/community/bcc/10-use-system-libbpf.patch
index 2d9160fd17..c77e15cf57 100644
--- a/community/bcc/10-use-system-libbpf.patch
+++ b/community/bcc/10-use-system-libbpf.patch
@@ -17,7 +17,7 @@ index 88df6e84..4ee79d46 100644
install (TARGETS bps DESTINATION share/bcc/introspection)
diff --git a/introspection/bps.c b/introspection/bps.c
-index 5ac80999..f3680251 100644
+index 5e510aa4..eb7bb0e3 100644
--- a/introspection/bps.c
+++ b/introspection/bps.c
@@ -8,6 +8,7 @@
@@ -29,7 +29,7 @@ index 5ac80999..f3680251 100644
#include "libbpf.h"
diff --git a/src/cc/CMakeLists.txt b/src/cc/CMakeLists.txt
-index bd34fd48..af781a33 100644
+index 571a4637..07aa3d42 100644
--- a/src/cc/CMakeLists.txt
+++ b/src/cc/CMakeLists.txt
@@ -10,8 +10,8 @@ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/frontends/clang)
@@ -103,10 +103,10 @@ index 12816757..bd26f69f 100644
#define BCC_MAX_ERRNO 4095
diff --git a/src/cc/bpf_module.cc b/src/cc/bpf_module.cc
-index 836c458f..7100e35d 100644
+index c27ce9c8..5f61a71c 100644
--- a/src/cc/bpf_module.cc
+++ b/src/cc/bpf_module.cc
-@@ -43,7 +43,7 @@
+@@ -44,7 +44,7 @@
#include "exported_files.h"
#include "libbpf.h"
#include "bcc_btf.h"
@@ -115,8 +115,21 @@ index 836c458f..7100e35d 100644
namespace ebpf {
+diff --git a/src/cc/frontends/clang/b_frontend_action.cc b/src/cc/frontends/clang/b_frontend_action.cc
+index cb1f5b1c..6a13f5d6 100644
+--- a/src/cc/frontends/clang/b_frontend_action.cc
++++ b/src/cc/frontends/clang/b_frontend_action.cc
+@@ -34,7 +34,7 @@
+ #include "loader.h"
+ #include "table_storage.h"
+ #include "arch_helper.h"
+-#include "libbpf/src/bpf.h"
++#include "bpf/libbpf.h"
+
+ #include "libbpf.h"
+
diff --git a/src/cc/libbpf.c b/src/cc/libbpf.c
-index 63f4894e..53d37f8e 100644
+index 8459ecf0..4e1d2b45 100644
--- a/src/cc/libbpf.c
+++ b/src/cc/libbpf.c
@@ -52,8 +52,8 @@
diff --git a/community/bcc/APKBUILD b/community/bcc/APKBUILD
index 81ec450073..d230595ec4 100644
--- a/community/bcc/APKBUILD
+++ b/community/bcc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Jensen <acjensen@gmail.com>
pkgname=bcc
-pkgver=0.10.0
-pkgrel=5
+pkgver=0.11.0
+pkgrel=0
pkgdesc="A toolkit for creating efficient kernel tracing and manipulation programs"
url="https://github.com/iovisor/bcc/"
arch="aarch64 x86 x86_64"
@@ -48,7 +48,7 @@ _doc() {
}
_tools() {
- depends="$pkgname py-$pkgname"
+ depends="$pkgname py3-$pkgname"
pkgdesc="$pkgdesc (tools)"
mkdir -p "$subpkgdir"/usr/share/bcc
@@ -72,5 +72,5 @@ _lua() {
mv "$pkgdir"/usr/bin/bcc-lua "$subpkgdir"/usr/bin
}
-sha512sums="92ba0f57d22af610ac81661526fed8bec80d502bcbc8aa5048ba7c50911247c020832db23afdcf9b555b142cd387c228cf7baa0ddc94067165403e362227f235 bcc-0.10.0.tar.gz
-e2f0cc063a13e2d5ad57db364e29c064f2c351b82bbd4013d613614adab3b9f4aa555ac71e06189807d32211fdef5c9520b4bc5df2db5de3db02123503d242a8 10-use-system-libbpf.patch"
+sha512sums="4854a5a15a89a8bd3a10daa6f0e831428316751280902cbdc74f3c6f78263ee1c58521ae9125804e72fec6482702818a5fec781436400640627e4b7c2fc189fb bcc-0.11.0.tar.gz
+f2aa0e3184f11a80d98f5a68d7f46799d471818dafb03d9683c09f33ed2400a3c570807ef6773d4011f0851217089f976ffeff9f5d3279a81e5f551dadc506b5 10-use-system-libbpf.patch"