aboutsummaryrefslogtreecommitdiffstats
path: root/community/biber/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-03 10:26:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 10:42:28 +0000
commitb9e9d4d48bbe0dd48a89fdf6b772f0ccd0faab59 (patch)
tree2a8e60b46b3c2c4b65ffee2cbfdba7cf7d3c23b2 /community/biber/APKBUILD
parent2b9526c277ed59ffe2c15ec359b7a7bf5f784f6f (diff)
downloadaports-b9e9d4d48bbe0dd48a89fdf6b772f0ccd0faab59.tar.bz2
aports-b9e9d4d48bbe0dd48a89fdf6b772f0ccd0faab59.tar.xz
community/biber: disable long year test on mips{el}
Re-organize CARCH check for brevity (so match armel as well) and use mipsel* not mipsel to cover out-of-tree mipseln8hf.
Diffstat (limited to 'community/biber/APKBUILD')
-rw-r--r--community/biber/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/biber/APKBUILD b/community/biber/APKBUILD
index 7f86e89a4d..8b83a6eac7 100644
--- a/community/biber/APKBUILD
+++ b/community/biber/APKBUILD
@@ -28,9 +28,10 @@ builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$builddir"
# Disable long year tests on 32 bit
- if [ $CARCH = "x86" ] || [ $CARCH = "armhf" ] || [ $CARCH = "armv7" ]; then
+ case "$CARCH" in arm*|mips|mipsel*|x86)
sed -i '/17000002/ s+.*+eq_or_diff("dummy", "dummy", "skip 32 bit");+' t/dateformats.t
- fi
+ ;;
+ esac
perl Build.PL installdirs=vendor
}