aboutsummaryrefslogtreecommitdiffstats
path: root/community/bitchx
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-29 14:02:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:09 +0000
commitb6c1182d5dfc4cfe5cd835d86c5f813a21ac9e44 (patch)
treecd056e4958a953a87b0831d82e46fa4ab0a0abe5 /community/bitchx
parent916070ca7ade71a252da326926cab7782849f912 (diff)
downloadaports-b6c1182d5dfc4cfe5cd835d86c5f813a21ac9e44.tar.bz2
aports-b6c1182d5dfc4cfe5cd835d86c5f813a21ac9e44.tar.xz
community/bitchx: move from main
Diffstat (limited to 'community/bitchx')
-rw-r--r--community/bitchx/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/community/bitchx/APKBUILD b/community/bitchx/APKBUILD
new file mode 100644
index 0000000000..f471639247
--- /dev/null
+++ b/community/bitchx/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=bitchx
+pkgver=1.2.1
+pkgrel=8
+pkgdesc="An IRC client"
+url="http://www.bitchx.org/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev="tcl-dev libressl-dev ncurses-dev"
+makedepends="$depends_dev coreutils"
+install=""
+subpackages="$pkgname-doc"
+source="https://downloads.sourceforge.net/project/bitchx/ircii-pana/bitchx-$pkgver/bitchx-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/bitchx-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-ssl \
+ --enable-ipv6 \
+ --with-plugins \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4da13a2dcfa17847168e50e62be4f67a bitchx-1.2.1.tar.gz"
+sha256sums="2d270500dd42b5e2b191980d584f6587ca8a0dbda26b35ce7fadb519f53c83e2 bitchx-1.2.1.tar.gz"
+sha512sums="d5e0a151c69a85cca2544db8478af9fbd8fca17f882993fab7f898a95221087bf6219ad2144caedecb5bc508dfa02fa724737c615fbda47aeb8df8298cdfd645 bitchx-1.2.1.tar.gz"