aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluedevil/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-09 21:23:37 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 15:14:31 -0300
commit49706d041ac8b8ab52953b7afc3ae68bd2011115 (patch)
treed5b39b0560d32cc1f88c104afa6596ce2d0926d1 /community/bluedevil/APKBUILD
parentcefb2ca485c59489dc1b41269aece862643902e6 (diff)
downloadaports-49706d041ac8b8ab52953b7afc3ae68bd2011115.tar.bz2
aports-49706d041ac8b8ab52953b7afc3ae68bd2011115.tar.xz
community/bluedevil: move from testing
Diffstat (limited to 'community/bluedevil/APKBUILD')
-rw-r--r--community/bluedevil/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
new file mode 100644
index 0000000000..693e4d1b31
--- /dev/null
+++ b/community/bluedevil/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=bluedevil
+pkgver=5.16.5
+pkgrel=0
+pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
+depends="kded bluez"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kwidgetsaddons-dev kdbusaddons-dev knotifications-dev kwindowsystem-dev kiconthemes-dev plasma-framework-dev ki18n-dev kio-dev bluez-qt-dev kded-dev kded shared-mime-info"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="de3c767413ede046ef39bc249c728c50f22db04ce1062956f9462214cf0d9dda0468ea3e463330663da720226a97b3bf935c5c138d282d066181faf0b6e55828 bluedevil-5.16.5.tar.xz"