aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluefish
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-10 15:44:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-10 15:44:03 -0300
commit772b8df9d52c4530662de3ab61955ca83cce5ba5 (patch)
treefb6fdd307818432c476e5e1aa1ceadb870d08bb0 /community/bluefish
parent2192f65f7df7582a35a356d5d33422d2f3ae9fac (diff)
downloadaports-772b8df9d52c4530662de3ab61955ca83cce5ba5.tar.bz2
aports-772b8df9d52c4530662de3ab61955ca83cce5ba5.tar.xz
community/bluefish: drop zenconding plugin
- Requires python2
Diffstat (limited to 'community/bluefish')
-rw-r--r--community/bluefish/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/bluefish/APKBUILD b/community/bluefish/APKBUILD
index 693dbba245..e3d6288362 100644
--- a/community/bluefish/APKBUILD
+++ b/community/bluefish/APKBUILD
@@ -2,17 +2,14 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=bluefish
pkgver=2.2.10
-pkgrel=1
+pkgrel=2
pkgdesc="Bluefish is an editor targeted towards programmers and webdevelopers"
url="http://bluefish.openoffice.nl/"
arch="all"
-license="GPL"
-makedepends="libtool libxml2-dev python2-dev gtk+3.0-dev enchant-dev \
- gucharmap-dev intltool"
+license="GPL-3.0-or-later"
+makedepends="libtool libxml2-dev gtk+3.0-dev enchant-dev gucharmap-dev intltool"
subpackages="$pkgname-lang $pkgname-doc"
-source="http://www.bennewitz.com/$pkgname/stable/source/$pkgname-$pkgver.tar.bz2"
-
-builddir=${srcdir}/${pkgname}-${pkgver}
+source="http://www.bennewitz.com/bluefish/stable/source/bluefish-$pkgver.tar.bz2"
prepare() {
default_prepare
@@ -20,15 +17,12 @@ prepare() {
}
build() {
- cd "$builddir"
- ./configure --prefix=/usr
- make
+ ./configure --prefix=/usr
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
-
+ make DESTDIR="$pkgdir" install
}
sha512sums="ddfad4c595d371dfd7ca5551c1771c2d82dbffcc90acda31bbd2a048730e24e2d1e37fbe847e5005d96acefdf5f38cb93785d23817e59624ecd7ea10bfbc3aeb bluefish-2.2.10.tar.bz2"