aboutsummaryrefslogtreecommitdiffstats
path: root/community/borgbackup/msgpack-fix.patch
diff options
context:
space:
mode:
authorSascha Paunovic <azarus@posteo.net>2018-05-28 13:22:17 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-28 13:43:33 +0200
commit1f7ec257bb50ba837776de403541856496328cbc (patch)
tree5f83ae771759e2d8b1ffde7cee72ba5b148bb681 /community/borgbackup/msgpack-fix.patch
parent2010a48eba70cc1905ed305173211fbdc246660a (diff)
downloadaports-1f7ec257bb50ba837776de403541856496328cbc.tar.bz2
aports-1f7ec257bb50ba837776de403541856496328cbc.tar.xz
community/borgbackup: ensure correct msgpack version is used in runtime
This fixes https://bugs.alpinelinux.org/issues/8893, caused by upstream error https://github.com/borgbackup/borg/issues/3753.
Diffstat (limited to 'community/borgbackup/msgpack-fix.patch')
-rw-r--r--community/borgbackup/msgpack-fix.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/borgbackup/msgpack-fix.patch b/community/borgbackup/msgpack-fix.patch
new file mode 100644
index 0000000000..67a44204c4
--- /dev/null
+++ b/community/borgbackup/msgpack-fix.patch
@@ -0,0 +1,22 @@
+--- borgbackup-1.1.5/setup.py.orig
++++ borgbackup-1.1.5/setup.py
+@@ -36,10 +36,15 @@
+ on_rtd = os.environ.get('READTHEDOCS')
+
+ install_requires = [
+- # msgpack pure python data corruption was fixed in 0.4.6.
+- # msgpack 0.5.0 was a bit of a troublemaker.
+- # also, msgpack dropped py34 support at 0.5.0.
+- 'msgpack-python>=0.4.6,<0.5.0',
++ # we are rather picky about msgpack versions, because a good working msgpack is
++ # very important for borg, see https://github.com/borgbackup/borg/issues/3753
++ # best versions seem to be 0.4.6, 0.4.7, 0.4.8 and 0.5.6:
++ 'msgpack-python >=0.4.6, <=0.5.6, !=0.5.0, !=0.5.1, !=0.5.2, !=0.5.3, !=0.5.4, !=0.5.5',
++ # if you can't satisfy the above requirement, these are versions that might
++ # also work ok, IF you make sure to use the COMPILED version of msgpack-python,
++ # NOT the PURE PYTHON fallback implementation: ==0.5.1, ==0.5.4
++ # using any other version is not supported by borg development, feel free to
++ # do it on your own risk (and after own testing).
+ ]
+
+ # note for package maintainers: if you package borgbackup for distribution,