aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-icons
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 18:29:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-16 18:30:14 -0300
commit20514d44bccd485c01e52d6b464e760af582becf (patch)
tree518ff0450d789aae18eb272aa9f7012c40174ea3 /community/breeze-icons
parente0faa35dfa896147cfa5415ed10d1228524bf212 (diff)
downloadaports-20514d44bccd485c01e52d6b464e760af582becf.tar.bz2
aports-20514d44bccd485c01e52d6b464e760af582becf.tar.xz
community/breeze-icons: make grep call -q instead of --quiet
Diffstat (limited to 'community/breeze-icons')
-rw-r--r--community/breeze-icons/APKBUILD7
-rw-r--r--community/breeze-icons/busybox-grep-q.patch29
2 files changed, 34 insertions, 2 deletions
diff --git a/community/breeze-icons/APKBUILD b/community/breeze-icons/APKBUILD
index a0ca247e6d..e331f53c5e 100644
--- a/community/breeze-icons/APKBUILD
+++ b/community/breeze-icons/APKBUILD
@@ -9,7 +9,9 @@ url="https://community.kde.org/Frameworks"
license="LGPL-3.0-or-later"
makedepends="extra-cmake-modules qt5-qtbase-dev"
checkdepends="bash"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/breeze-icons-$pkgver.tar.xz"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/breeze-icons-$pkgver.tar.xz
+ busybox-grep-q.patch
+ "
prepare() {
default_prepare
@@ -35,4 +37,5 @@ package() {
cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="d66ee651d8d69e5e162cf2f74f1f84255db121e90e8a2150813a06a918af8642b41a23b3b5885b8b10d23ec0a3bdb654affca78790b6d2158833a34e7bc1d7d3 breeze-icons-5.68.0.tar.xz"
+sha512sums="d66ee651d8d69e5e162cf2f74f1f84255db121e90e8a2150813a06a918af8642b41a23b3b5885b8b10d23ec0a3bdb654affca78790b6d2158833a34e7bc1d7d3 breeze-icons-5.68.0.tar.xz
+e4ac354dbb75519d2699a2a95b6810950a22cfc2b550557426e1ab9d57f9e778fc6cda4d205626158c9fb4c30bb00fa32f1a02bbbaa021136ff660bb93926080 busybox-grep-q.patch"
diff --git a/community/breeze-icons/busybox-grep-q.patch b/community/breeze-icons/busybox-grep-q.patch
new file mode 100644
index 0000000000..32d92aca3a
--- /dev/null
+++ b/community/breeze-icons/busybox-grep-q.patch
@@ -0,0 +1,29 @@
+diff --git a/generate-24px-versions.sh b/generate-24px-versions.sh
+index 470c755..4d73a83 100644
+--- a/generate-24px-versions.sh
++++ b/generate-24px-versions.sh
+@@ -36,10 +36,10 @@ for INPUT_FILE in {devices,actions,places,status}/22/*.svg; do
+ cp "$INPUT_FILE" "$OUTPUT_FILE"
+
+ # Change the size of the bounding box
+- if grep --quiet '"0 0 22 22' "$OUTPUT_FILE"; then
++ if grep -q '"0 0 22 22' "$OUTPUT_FILE"; then
+ sed_i -e 's/"0 0 22 22/"0 0 24 24/g' "$OUTPUT_FILE"
+ # YOU
+- elif grep --quiet 'width="22"' "$OUTPUT_FILE"; then
++ elif grep -q 'width="22"' "$OUTPUT_FILE"; then
+ sed_i -e 's/width="22"/width="24"/g' "$OUTPUT_FILE"
+ sed_i -e 's/height="22"/height="24"/g' "$OUTPUT_FILE"
+ else
+@@ -48,9 +48,9 @@ for INPUT_FILE in {devices,actions,places,status}/22/*.svg; do
+ fi
+
+ # Group all the paths and transform them to fit in the center of a 24px box
+- if grep --quiet "</defs>" "$OUTPUT_FILE"; then
++ if grep -q "</defs>" "$OUTPUT_FILE"; then
+ sed_i -e 's|</defs>|</defs><g transform="translate(1,1)">|g' "$OUTPUT_FILE"
+- elif grep --quiet "</style>" "$OUTPUT_FILE"; then
++ elif grep -q "</style>" "$OUTPUT_FILE"; then
+ sed_i -e 's|</style>|</style><g transform="translate(1,1)">|g' "$OUTPUT_FILE"
+ else
+ # No stylesheet or defs tag; put the group at the end of the opening svg tag