aboutsummaryrefslogtreecommitdiffstats
path: root/community/breeze-plymouth
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-18 16:13:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-10-20 12:24:41 -0300
commitb3553abc60cd45495f8a252a5a06ca25c6749952 (patch)
tree89dc4e90e78d313a485ccb0fd7264c132d9d4381 /community/breeze-plymouth
parent9a177212eb91a159b575312d0824a790ad551adf (diff)
downloadaports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.bz2
aports-b3553abc60cd45495f8a252a5a06ca25c6749952.tar.xz
community/plasma: upgrade to 5.17.0
Diffstat (limited to 'community/breeze-plymouth')
-rw-r--r--community/breeze-plymouth/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/breeze-plymouth/APKBUILD b/community/breeze-plymouth/APKBUILD
index 02e41af438..0f02f76954 100644
--- a/community/breeze-plymouth/APKBUILD
+++ b/community/breeze-plymouth/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=breeze-plymouth
-pkgver=5.16.5
+pkgver=5.17.0
pkgrel=0
arch="all"
url="https://kde.org/"
@@ -12,20 +12,25 @@ makedepends="extra-cmake-modules plymouth-dev"
source="https://download.kde.org/stable/plasma/$pkgver/breeze-plymouth-$pkgver.tar.xz"
options="!check" # No tests
-build() {
- # Get distro information to display on the splash screen
- source /etc/os-release
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
- cmake \
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DDISTRO_NAME="$NAME" \
- -DDISTRO_VERSION="$VERSION_ID"
+ -DDISTRO_NAME="$(grep PRETTY_NAME /etc/os-release | awk -F = '{ print $2 }')" \
+ -DDISTRO_VERSION="$(grep VERSION_ID /etc/os-release | awk -F = '{ print $2 }')"
make
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="2934d43c44b5683964fd14b3a5498c41989c5fb69182b29cef9bc588470c299f16662028e8c2101228a3c3299789ffdc21e33ed49d90965a2add2d9bd79a4ee6 breeze-plymouth-5.16.5.tar.xz"
+sha512sums="67270db7d97a7d9c7a7bbebf3f10860547edd500f03fcebcb85c065ca243a5ed00eb2f2e8db2c4cba3dcefba5109b0f8c4ba6a17c93b56e6e1ab185cf8460789 breeze-plymouth-5.17.0.tar.xz"