aboutsummaryrefslogtreecommitdiffstats
path: root/community/brightnessctl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-11 07:23:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 07:35:33 -0300
commit2ca1e3301d2f943d3ad978b814d09de18fa5bfed (patch)
tree0d5c34146dba0728b2445c2e0743a24fde970084 /community/brightnessctl
parent5635b2bd9233b6b86fcc0c271020bfe82d37895f (diff)
downloadaports-2ca1e3301d2f943d3ad978b814d09de18fa5bfed.tar.bz2
aports-2ca1e3301d2f943d3ad978b814d09de18fa5bfed.tar.xz
community/brightnessctl: move from testing
Diffstat (limited to 'community/brightnessctl')
-rw-r--r--community/brightnessctl/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/brightnessctl/APKBUILD b/community/brightnessctl/APKBUILD
new file mode 100644
index 0000000000..06af021be4
--- /dev/null
+++ b/community/brightnessctl/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=brightnessctl
+pkgver=0.4
+pkgrel=0
+pkgdesc="Program to read and control device brightness"
+options="!check" # No testsuite
+url="https://github.com/Hummer12007/brightnessctl"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Hummer12007/brightnessctl/archive/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="f0e1abe4dd7fc66a7990c0c42ecd9af079ba397fb0a49d339c5927fe639edbce4c30ecfcd16c3e0bf58de2eb4ca611dd1e1ce40eec9f95fe3960189c5e5396d8 brightnessctl-0.4.tar.gz"