aboutsummaryrefslogtreecommitdiffstats
path: root/community/cage
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-13 18:34:14 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-14 16:32:14 -0300
commita0fd3558160588a9f593c949fc7b0071ab071e7a (patch)
treea00c8dbd54261b7ef95e11800d0bb336f8a4a726 /community/cage
parent89a5bbd018626f7dc494b4dd29ee1ff7379bfd8e (diff)
downloadaports-a0fd3558160588a9f593c949fc7b0071ab071e7a.tar.bz2
aports-a0fd3558160588a9f593c949fc7b0071ab071e7a.tar.xz
community/cage: move from testing
Diffstat (limited to 'community/cage')
-rw-r--r--community/cage/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/cage/APKBUILD b/community/cage/APKBUILD
new file mode 100644
index 0000000000..d681f64321
--- /dev/null
+++ b/community/cage/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
+# Contributor: Will Sinatra <wpsinatra@gmail.com>
+pkgname=cage
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A Wayland Kiosk"
+url="https://github.com/Hjdskes/cage"
+arch="all"
+license="MIT"
+depends="xorg-server-xwayland"
+makedepends="meson cmake wlroots-dev wayland-protocols"
+options="!check" #No checks
+source="$pkgname"-"$pkgver".tar.gz::https://github.com/Hjdskes/cage/archive/v"$pkgver".tar.gz
+
+prepare() {
+ meson --buildtype=release -Dxwayland=true --prefix /usr "$srcdir/build"
+}
+
+build() {
+ ninja -C "$srcdir/build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "$srcdir/build" install
+}
+
+sha512sums="f071f04f1ff7d2b89ae72238ef1a28fd3fbc389803e4a4fe0c3d938c7a2a1cc962b63929d081d975f98131ff6dd9637762e8036bb320277e2580f0cbeb0c6201 cage-0.1.1.tar.gz"