aboutsummaryrefslogtreecommitdiffstats
path: root/community/camlp4
diff options
context:
space:
mode:
authorAnil Madhavapeddy <anil@recoil.org>2016-12-01 18:23:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-02 21:20:45 +0000
commita854576a021603f62dc02bd21baf7af38dae75bb (patch)
treea33c790d66bde1888c404d4233e6fed919282060 /community/camlp4
parentc9ebcfc8f43c84d6e4a85a6a11067ea91aef8078 (diff)
downloadaports-a854576a021603f62dc02bd21baf7af38dae75bb.tar.bz2
aports-a854576a021603f62dc02bd21baf7af38dae75bb.tar.xz
community/camlp4: move from testing to community
Diffstat (limited to 'community/camlp4')
-rw-r--r--community/camlp4/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/camlp4/APKBUILD b/community/camlp4/APKBUILD
new file mode 100644
index 0000000000..0db541a1be
--- /dev/null
+++ b/community/camlp4/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Jon Ong <jonongjs@rottenmage.com>
+# Maintainer: Anil Madhavapeddy <anil@recoil.org>
+pkgname=camlp4
+pkgver=4.03
+_versuffix='+1'
+pkgrel=0
+pkgdesc="Caml preprocessor and pretty-printer"
+url="https://github.com/ocaml/camlp4/releases"
+arch="all !x86"
+license="LGPL2"
+depends="ocaml"
+makedepends="ocamlbuild"
+options="!makeflags !emptydirs staticlibs"
+install=""
+subpackages=""
+source="${pkgver}-${pkgver}${_versuffix}.tar.gz::https://github.com/ocaml/camlp4/archive/${pkgver}${_versuffix}.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver${_versuffix/+/-}"
+build() {
+ cd "$builddir"
+
+ ./configure || return 1
+ make -j1 all camlp4/META || return 1
+}
+
+package() {
+ cd "$builddir"
+
+ make BINDIR="$pkgdir/usr/bin" \
+ LIBDIR="$pkgdir/usr/lib/ocaml" \
+ PKGDIR="$pkgdir/usr/lib/ocaml" \
+ install install-META || return 1
+}
+md5sums="65ece8d2c8f4b1e06d62323e78759a7c 4.03-4.03+1.tar.gz"
+sha256sums="6eefeacced81cca59ddf90c2538505fd5cd6596a3fc1acf4971e9796c2e7f2ae 4.03-4.03+1.tar.gz"
+sha512sums="0a329e18deffebb5245415f822f91e692076fca4dbe38748f18e72f417ce7354faed744fdff25f9976659192cb02d56ceb2cf1be5c64da463413ec4a28a9d3ac 4.03-4.03+1.tar.gz"