aboutsummaryrefslogtreecommitdiffstats
path: root/community/cassandra-cpp-driver
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-08 13:18:17 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-08 13:11:12 +0200
commit2a0feee39134d45699f08e45057e5ca832938ba1 (patch)
treebb42cebdc5f70b40eda0078ef4faa5417bcae0e8 /community/cassandra-cpp-driver
parent18d6aeb55d768dd3405059c12a15528d05c4bdd6 (diff)
downloadaports-2a0feee39134d45699f08e45057e5ca832938ba1.tar.bz2
aports-2a0feee39134d45699f08e45057e5ca832938ba1.tar.xz
main/libuv: upgrade to 1.21.0 and rebuild dependent packages
Diffstat (limited to 'community/cassandra-cpp-driver')
-rw-r--r--community/cassandra-cpp-driver/APKBUILD7
-rw-r--r--community/cassandra-cpp-driver/libuv-1.21-compat.patch25
2 files changed, 30 insertions, 2 deletions
diff --git a/community/cassandra-cpp-driver/APKBUILD b/community/cassandra-cpp-driver/APKBUILD
index 07b8d8bc17..cf00d30a25 100644
--- a/community/cassandra-cpp-driver/APKBUILD
+++ b/community/cassandra-cpp-driver/APKBUILD
@@ -12,7 +12,9 @@ options="!check" # FIXME: cassandra_integration_tests won't link
depends=""
makedepends="cmake make libressl-dev libuv-dev"
subpackages="$pkgname-dev"
-source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz"
+source="$_pkgreal-$pkgver.tar.gz::https://github.com/datastax/cpp-driver/archive/$pkgver.tar.gz
+ libuv-1.21-compat.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -31,4 +33,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz"
+sha512sums="1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8 cpp-driver-2.8.1.tar.gz
+5932f13a666b95a40d938f2cc6f3b6eb2107d5d569ff67be470913275816109f7a32426cf1e39ef950b9ba1c7f78063c388805b4106368f9f1527ff15c422241 libuv-1.21-compat.patch"
diff --git a/community/cassandra-cpp-driver/libuv-1.21-compat.patch b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
new file mode 100644
index 0000000000..f2070c985e
--- /dev/null
+++ b/community/cassandra-cpp-driver/libuv-1.21-compat.patch
@@ -0,0 +1,25 @@
+From 0edf3d2eff88d7594ed7dc070f889b1bcacb677f Mon Sep 17 00:00:00 2001
+From: "Tobias C. Berner" <tcberner@FreeBSD.org>
+Date: Sun, 24 Jun 2018 08:25:53 +0200
+Subject: [PATCH] CPP-616 - Use uv/version.h as version file for libuv v1.21.0+
+
+libuv v1.21.0+ changed where the version file is located.
+
+Patch-Source: https://github.com/datastax/cpp-driver/commit/0edf3d2eff88d7594ed7dc070f889b1bcacb677f
+---
+ cmake/modules/CppDriver.cmake | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/cmake/modules/CppDriver.cmake b/cmake/modules/CppDriver.cmake
+index 92c243d5..098374f9 100644
+--- a/cmake/modules/CppDriver.cmake
++++ b/cmake/modules/CppDriver.cmake
+@@ -372,6 +372,8 @@ macro(CassUseLibuv)
+
+ if (EXISTS "${LIBUV_INCLUDE_DIR}/uv-version.h")
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv-version.h")
++ elseif (EXISTS "${LIBUV_INCLUDE_DIR}/uv/version.h")
++ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv/version.h")
+ else()
+ set(LIBUV_VERSION_HEADER_FILE "${LIBUV_INCLUDE_DIR}/uv.h")
+ endif()