aboutsummaryrefslogtreecommitdiffstats
path: root/community/certbot-apache
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 10:14:34 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-12-15 10:14:34 +0000
commitf334d8cecf74365fb295c77d7d7c9921470bbd4e (patch)
tree0cbf54e2c956389fbb4af904edb2a81f13eee088 /community/certbot-apache
parent86f3d2bec7e1bdb041c29534bbe7235dcb74eb93 (diff)
downloadaports-f334d8cecf74365fb295c77d7d7c9921470bbd4e.tar.bz2
aports-f334d8cecf74365fb295c77d7d7c9921470bbd4e.tar.xz
community/certbot-apache: new aport
Diffstat (limited to 'community/certbot-apache')
-rw-r--r--community/certbot-apache/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/certbot-apache/APKBUILD b/community/certbot-apache/APKBUILD
new file mode 100644
index 0000000000..ef86770bf0
--- /dev/null
+++ b/community/certbot-apache/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname="certbot-apache"
+pkgver="1.0.0"
+pkgrel=0
+pkgdesc="Apache plugin for Certbot client"
+url="https://pypi.python.org/pypi/$pkgname"
+arch="noarch"
+license="Apache"
+depends="certbot py3-acme py3-mock py3-augeas
+py3-setuptools py3-zope-component py3-zope-interface"
+checkdepends="py3-pytest"
+source="https://pypi.io/packages/source/c/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="25cfaf8d58f52c502cf7a0cc70f279ccc7eb44f16dc509b32cd15310fff52c5b92c2cf0ecbc55abab830659219cf4c458363dfd4b8391d23f098d5afce3f636d certbot-apache-1.0.0.tar.gz"