aboutsummaryrefslogtreecommitdiffstats
path: root/community/cfengine
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-12-20 12:29:03 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-20 12:34:45 +0100
commitdc3b70dd0ecbb59509fe06119966422e9f7d43f2 (patch)
tree7ad3046f58506ce8d4bf04f5b0ff44505f078cad /community/cfengine
parentbb28d113ad4d8b23d1bbfdf3af46ec76b1b74182 (diff)
downloadaports-dc3b70dd0ecbb59509fe06119966422e9f7d43f2.tar.bz2
aports-dc3b70dd0ecbb59509fe06119966422e9f7d43f2.tar.xz
community/cfengine: fix needed symlinks
The tools seems to require binaries to be available from /var/lib/cfengine/bin. https://tracker.mender.io/browse/CFE-2936 we also add a post-install that creates the keys.
Diffstat (limited to 'community/cfengine')
-rw-r--r--community/cfengine/APKBUILD16
-rw-r--r--community/cfengine/cfengine.post-install3
2 files changed, 16 insertions, 3 deletions
diff --git a/community/cfengine/APKBUILD b/community/cfengine/APKBUILD
index 350bbf4b84..60b6061114 100644
--- a/community/cfengine/APKBUILD
+++ b/community/cfengine/APKBUILD
@@ -1,11 +1,12 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cfengine
pkgver=3.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="A systems administration tool for networks"
url="http://www.cfengine.com/"
arch="all"
license="GPL-3.0"
+install="$pkgname.post-install"
makedepends="$depends_dev lmdb-dev openssl-dev bison flex-dev
acl-dev pcre-dev linux-headers"
subpackages="$pkgname-doc $pkgname-masterfiles::noarch"
@@ -37,11 +38,22 @@ build() {
--with-lmdb \
--without-pam
make
+
+ cd "$builddirmasterfiles"
+ ./configure \
+ --prefix=/var/lib/cfengine
+ make
}
package() {
cd "$builddir"
make install DESTDIR="$pkgdir"
+
+ # not FHS but the tools seems to require those
+ install -d "$pkgdir"/var/lib/cfengine/bin
+ for i in "$pkgdir"/usr/bin/*; do
+ ln -s ../../../../usr/bin/${i##*/} "$pkgdir"/var/lib/cfengine/bin/
+ done
}
masterfiles() {
@@ -49,8 +61,6 @@ masterfiles() {
depends="cfengine"
cd "$builddirmasterfiles"
- ./configure \
- --prefix=/var/lib/cfengine
make install DESTDIR="$subpkgdir"
}
diff --git a/community/cfengine/cfengine.post-install b/community/cfengine/cfengine.post-install
new file mode 100644
index 0000000000..d29ea6f0a7
--- /dev/null
+++ b/community/cfengine/cfengine.post-install
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cf-key || true