aboutsummaryrefslogtreecommitdiffstats
path: root/community/chezmoi
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-12-06 21:43:31 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-12-06 21:43:41 +0000
commit87e52be140741344ea24ae0e70f9a221330de2da (patch)
tree6c21270a0d279ada7ebc362279a18fb7d876b111 /community/chezmoi
parent3a6c111c786c9574aadbec4c8cda524a8a32c1b0 (diff)
downloadaports-87e52be140741344ea24ae0e70f9a221330de2da.tar.bz2
aports-87e52be140741344ea24ae0e70f9a221330de2da.tar.xz
community/chezmoi: move from testing
Diffstat (limited to 'community/chezmoi')
-rw-r--r--community/chezmoi/APKBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/community/chezmoi/APKBUILD b/community/chezmoi/APKBUILD
new file mode 100644
index 0000000000..bd98a57aab
--- /dev/null
+++ b/community/chezmoi/APKBUILD
@@ -0,0 +1,80 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname="chezmoi"
+pkgver="1.7.5"
+pkgrel=1
+pkgdesc="Manage your dotfiles across multiple machines, securely."
+url="https://www.chezmoi.io/"
+arch="all"
+license="MIT"
+makedepends="go"
+options="!check chmod-clean" # no test suite
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion:bashcomp:noarch
+ $pkgname-zsh-completion:zshcomp:noarch
+ $pkgname-fish-completion:fishcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/twpayne/chezmoi/archive/v$pkgver.tar.gz"
+
+export GOPATH="$srcdir"
+
+build() {
+ go build \
+ -ldflags "
+ -X \"github.com/twpayne/chezmoi/cmd.VersionStr=$pkgver\" \
+ -X \"github.com/twpayne/chezmoi/cmd.Date=$(date --utc +%Y-%M-%dT%H:%I:%SZ)\" \
+ -X \"github.com/twpayne/chezmoi/cmd.DocsDir=/usr/share/doc/chezmoi/\"
+ " \
+ -tags noupgrade \
+ -tags noembeddocs
+ make completions
+}
+
+package() {
+ install -Dm0755 chezmoi "$pkgdir"/usr/bin/chezmoi
+}
+
+doc() {
+ default_doc
+ mkdir -p "$subpkgdir/usr/share/doc/chezmoi"
+ ls -l "$builddir"/docs
+ cp "$builddir/docs/"* "$subpkgdir/usr/share/doc/chezmoi"
+}
+
+bashcomp() {
+ pkgdesc="additional scripts for bash like shell completion"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ cd "$builddir"
+ install -Dm0644 completions/chezmoi-completion.bash \
+ "$subpkgdir"/usr/share/bash-completion/completions/$pkgname
+}
+
+zshcomp() {
+ pkgdesc="additional scripts for zsh like shell completion"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ cd "$builddir"
+ install -Dm0644 completions/chezmoi.zsh \
+ "$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
+}
+
+fishcomp() {
+ pkgdesc="additional scripts for fish like shell completion"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel fish"
+
+ cd "$builddir"
+ install -Dm0644 completions/chezmoi.fish \
+ "$subpkgdir"/usr/share/fish/site-functions/_$pkgname
+}
+
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
+sha512sums="e63a4d62d3c788931f7c3691c26e51062677f9cee4d2d708d18ca70578b01bde85c757104de9296349ac3e23f029ef05a55ea5ccc3b353a07a748e2fc3d4290d chezmoi-1.7.5.tar.gz"