aboutsummaryrefslogtreecommitdiffstats
path: root/community/chromium/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-09-30 13:11:25 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-30 13:11:25 +0200
commitaa03363e4923e2745456359019c2dc08089ab446 (patch)
tree1ea625f4f9c1da39c97ddffde2bc08b3589f1bf9 /community/chromium/APKBUILD
parentf8f12a1762ad21637c24bf91b05725e792871b0f (diff)
downloadaports-aa03363e4923e2745456359019c2dc08089ab446.tar.bz2
aports-aa03363e4923e2745456359019c2dc08089ab446.tar.xz
community/chromium: move from main
Diffstat (limited to 'community/chromium/APKBUILD')
-rw-r--r--community/chromium/APKBUILD254
1 files changed, 254 insertions, 0 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
new file mode 100644
index 0000000000..8307f5adaa
--- /dev/null
+++ b/community/chromium/APKBUILD
@@ -0,0 +1,254 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=chromium
+pkgver=45.0.2454.101
+pkgrel=0
+pkgdesc="chromium web browser"
+url="http://www.chromium.org/"
+arch="x86_64"
+license="BSD"
+depends="xdg-utils"
+depends_dev="alsa-lib-dev libevent-dev libpng-dev jpeg-dev cairo-dev cups-dev
+ mesa-dev libcap-dev dbus-glib-dev gtk+-dev libxml2-dev freetype-dev
+ jpeg-dev libxslt-dev libxtst-dev icu-dev flac-dev speex-dev
+ hunspell-dev libxinerama-dev ffmpeg-dev nss-dev libwebp-dev bzip2-dev
+ libvpx-dev sqlite-dev libelf-dev libgcrypt-dev zlib-dev
+ gnutls-dev mesa-dev libxcursor-dev libxcomposite-dev krb5-dev
+ libxrandr-dev libxscrnsaver-dev pciutils-dev eudev-dev libexif-dev
+ hwdata-usb ninja libbsd-dev harfbuzz-dev snappy-dev
+ bsd-compat-headers openssl-dev libre2-dev jsoncpp-dev minizip-dev
+ linux-headers"
+makedepends="$depends_dev xdg-utils yasm gperf bison flex perl python bash
+ paxmark findutils"
+install=""
+options=suid
+subpackages="$pkgname-doc $pkgname-chromedriver"
+source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
+ chromium-launcher.sh
+ chromium.conf
+ chromium.desktop
+ google-api.keys
+
+ musl-fixes.patch
+ no-execinfo.patch
+ resolver.patch
+ no-mallinfo.patch
+ no-getcontext.patch
+ musl-sandbox.patch
+
+ chromium-system-jinja-r7.patch
+ chromium-widevine.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+case "${CARCH}" in
+ x86_64) target_arch=x64;;
+ x86) target_arch=ia32;;
+ arm) target_arch=arm;;
+esac
+
+prepare() {
+ cd "$_builddir"
+
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # Remove bundled ICU; its header files appear to get picked up instead of
+ # the system ones, leading to errors during the final link stage.
+ # https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
+ find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
+}
+
+build() {
+ cd "$_builddir"
+
+ # currently does not build with system vpx 1.4
+ # remoting/codec/video_encoder_vpx.cc:308:10: error:
+ # 'vpx_codec_control_VP9E_GET_ACTIVEMAP' was not declared in this scope
+ local vpx=0
+ # reusable system library settings
+ local use_system="
+ -Duse_system_bzip2=1
+ -Duse_system_flac=1
+ -Duse_system_harfbuzz=1
+ -Duse_system_icu=1
+ -Duse_system_jsoncpp=1
+ -Duse_system_libevent=1
+ -Duse_system_libjpeg=1
+ -Duse_system_libpng=1
+ -Duse_system_libvpx=$vpx
+ -Duse_system_libxml=1
+ -Duse_system_snappy=1
+ -Duse_system_xdg_utils=1
+ -Duse_system_yasm=1
+ -Duse_system_nspr=1
+ -Duse_system_re2=1
+ -Duse_system_speex=1
+ -Duse_system_libwebp=1
+ -Duse_system_libxslt=1
+ -Duse_system_zlib=1
+ -Duse_system_minizip=1
+ "
+
+ msg "Replacing gyp files"
+ build/linux/unbundle/replace_gyp_files.py ${use_system} || return 1
+
+ ##############################################################
+ # Please dont use these keys outside of Alpine Linux project #
+ # You can create your own at: #
+ # http://www.chromium.org/developers/how-tos/api-keys #
+ ##############################################################
+ eval "$(base64 -d < $srcdir/google-api.keys)"
+
+ msg "Running gyp_chromium"
+ build/gyp_chromium --depth=. \
+ ${use_system} \
+ -Dgoogle_api_key="$_google_api_key" \
+ -Dgoogle_default_client_id="$_google_default_client_id" \
+ -Dgoogle_default_client_secret="$_google_default_client_secret" \
+ -Dwerror= \
+ -Dclang=0 \
+ -Dpython_ver=2.7 \
+ -Dlinux_link_gsettings=1 \
+ -Dlinux_link_libpci=1 \
+ -Dlinux_link_libspeechd=0 \
+ -Dlinux_strip_binary=1 \
+ -Dlinux_use_bundled_binutils=0 \
+ -Dlinux_use_bundled_gold=0 \
+ -Dlinux_use_gold_flags=0 \
+ -Dicu_use_data_file_flag=0 \
+ -Dlogging_like_official_build=1 \
+ -Dlibspeechd_h_prefix=speech-dispatcher/ \
+ -Dffmpeg_branding=Chrome \
+ -Dproprietary_codecs=1 \
+ -Duse_allocator=none \
+ -Duse_gnome_keyring=0 \
+ -Dusb_ids_path=/usr/share/hwdata/usb.ids \
+ -Duse_mojo=0 \
+ -Duse_gconf=0 \
+ -Duse_pulseaudio=0 \
+ -Denable_hotwording=0 \
+ -Ddisable_fatal_linker_warnings=1 \
+ -Ddisable_glibc=1 \
+ -Ddisable_nacl=1 \
+ -Ddisable_pnacl=1 \
+ -Dtarget_arch="$target_arch" \
+ -Drelease_extra_cflags="$CFLAGS" \
+ -Ddisable_sse2=1 \
+ || return 1
+
+ msg "Ninja turtles GO!"
+ # build mksnapshot and paxmark it
+ ninja -C out/Release mksnapshot || return 1
+ paxmark -m out/Release/mksnapshot || return 1
+
+ # finish rest of the build
+ ninja -C out/Release chrome chrome_sandbox chromedriver || return 1
+ paxmark -m out/Release/chrome || return 1
+}
+
+package() {
+ cd "$_builddir"
+ local bin pak
+
+ for bin in chrome natives_blob.bin snapshot_blob.bin; do
+ install -Dm755 out/Release/$bin \
+ "$pkgdir"/usr/lib/$pkgname/$bin || return 1
+ done
+
+ install -Dm4755 "$_builddir"/out/Release/chrome_sandbox \
+ "$pkgdir"/usr/lib/$pkgname/chrome-sandbox || return 1
+
+ for pak in out/Release/*.pak; do
+ install -Dm644 $pak \
+ "$pkgdir"/usr/lib/$pkgname/${pak##*/} || return 1
+ done
+
+ install -Dm755 "$srcdir"/chromium-launcher.sh \
+ "$pkgdir"/usr/lib/$pkgname/chromium-launcher.sh || return 1
+
+ cp -r out/Release/locales "$pkgdir"/usr/lib/$pkgname/ || return 1
+
+ install -Dm644 out/Release/chrome.1 \
+ "$pkgdir"/usr/share/man/man1/chrome.1 || return 1
+
+ install -Dm644 out/Release/chrome.1 \
+ "$pkgdir"/usr/share/man/man1/chromium.1 || return 1
+
+ # It is important that we name the target "chromium-browser",
+ # xdg-utils expect it; bug #355517.
+ mkdir -p "$pkgdir"/usr/bin || return 1
+ cd "$pkgdir"/usr/bin || return 1
+ ln -sf /usr/lib/$pkgname/chromium-launcher.sh \
+ chromium-browser || return 1
+ ln -sf /usr/lib/$pkgname/chromedriver || return 1
+ cd "$_builddir"
+
+ install -Dm644 "$srcdir"/chromium.conf \
+ "$pkgdir"/etc/chromium/chromium.conf || return 1
+
+ install -Dm644 "$srcdir"/chromium.desktop \
+ "$pkgdir"/usr/share/applications/chromium.desktop
+
+ for size in 22 24 48 64 128 256; do
+ install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ for size in 16 32; do
+ install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+}
+
+chromedriver() {
+ pkgdesc="WebDriver driver for the Chromium Browser"
+ install -Dm755 "$_builddir"/out/Release/chromedriver \
+ "$subpkgdir"/usr/lib/$pkgname/chromedriver || return 1
+}
+
+md5sums="501bae19c33b3888578a9d92a493a17e chromium-45.0.2454.101.tar.xz
+b6d015c1da85aa65ee21bc974c7fc7d2 chromium-launcher.sh
+c5aa73a87d4b88cce9f1a680ca691bb6 chromium.conf
+2962ac6259e39a797d441daf43aa49c9 chromium.desktop
+2d2ee5f22d65c756871301b4a407f4ca google-api.keys
+4d51f367a9220703f5f7dd962388b5a7 musl-fixes.patch
+00ae59dd9d09c60a116fd0133f9f3a60 no-execinfo.patch
+af047840f31e99aa36be04edc3482afd resolver.patch
+5c69e07f1738f11632e8d9f27cc85826 no-mallinfo.patch
+2c8de771a7c0e5e0e9fc68fa978785f7 no-getcontext.patch
+4f22f0d05448c49d6501386523a081ba musl-sandbox.patch
+97b1578585ab600ed9adef4f341ccd80 chromium-system-jinja-r7.patch
+de717d6430532f34fe161035dfdafcdf chromium-widevine.patch"
+sha256sums="1b682dcaae9c89b2ebfdb192bb2f73c78c5b30a55103e7198fa3c1e21fed85fb chromium-45.0.2454.101.tar.xz
+89f1eb19d1ed998a190045ea173959f01faee3490d58a6a34ca3fe21228e569f chromium-launcher.sh
+b466559340a36998354a0577325fe533d9e6b74c24a15b7599671171506bf128 chromium.conf
+3ae90cea7503d0039de53448ed112b9bc0cb5a09f6b0045506eb777fc23517e5 chromium.desktop
+267ba8ff50574e51d2582c4fca9b9e14f7225c1fa064d135cbceff9cef2324ac google-api.keys
+55150c9f0671789b998d8f858e7c8640e30331b92912dea0a19458c9d0c3f31c musl-fixes.patch
+505a55c28e971e067f189e3a1ce697d711cec82a765d81f78eb49ec1f6df56cf no-execinfo.patch
+f16c63d4188fe56732dc6760307795ba4059452c4cf3de1460cbcb2616011511 resolver.patch
+d746414cde6c7fc1836406cc2f954387dc75c755141b2dd0126eb885ab411638 no-mallinfo.patch
+ea79f9a46116c8b56bbc69d226abd9252e4ae4d946ca695203f2298279cc2211 no-getcontext.patch
+20fcb99022f3a737dceea7349da61e12a85834c0ab65a02009b6f56acb8b0f07 musl-sandbox.patch
+872f5a38d8263b14308bb117828496a4093d0e6ad755d39d2c5e6857314fe071 chromium-system-jinja-r7.patch
+1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch"
+sha512sums="cab9566de6d6b582f0b78a3ef2ed591830976fdf838e7780a380eb0caed2d6649ceee50ce2c017406e18ac8bfa92fd6a43a6677f0984a4af8de0723db4d9312b chromium-45.0.2454.101.tar.xz
+b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
+f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
+e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
+2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
+47d2fa2e3cad35e6eca5de9ffad1eacdce7c82e4da4579aa08e7fde0fb5690b9925c8f925b484f012ce1eaf22b18350e2fbdd5f38301c45b390da4393158bf79 musl-fixes.patch
+4f756d3e404033f7a36b38266176b7302f7e2a2e78c9f8b8d362a53a3dbdc675cdaa581393a70c23a29135b34566cf4109513cb13a289dc111bbce65ec065ebd no-execinfo.patch
+987f18d37824676e5d874a6fde1099bcc558920e7781de5f34e612411013e4fac9ca421a3cce1ed5f82401c4d54212b6f47a0a856892a78543b8e400a4bb0489 resolver.patch
+c8ff8d3d2c5948a8c9ae0ccc8625ae6116071af19b1d7d2bc2597b0876084de42565537abcbb96b150176e04de7a288ab7a9116e038fe83dd6816c7c5b2ae235 no-mallinfo.patch
+42d9a6ebea2d95cdc169b921cc1a1b846cf500997059fd3084de09e21f00b63b76e60c6124f4af247d402ff5ca3f4bf8867a6f2c78198c05b4273ca01fb29241 no-getcontext.patch
+cc61407bae55523fd3d0b43be7cf827cd6a648314a81f8d78f830e60cb215ede6c585d8755e9c870bb98955a4d3679205cbefde6f4efcb0e48469169167823eb musl-sandbox.patch
+10bcc6a467b6766d13b5e41e7b7dcdbd62de7c04daad16c83037e88043032a0c118627029f91ef8a2a57faaaebc8b6f4ee16e8d1fecb5921d0d49efd60a27863 chromium-system-jinja-r7.patch
+4a11b46afa8ce84bd23a8c506301b5848ee4291a764f3aed282b8a98706ece16cf9346dec6cc71b1e17812b15f43a5cbc7bc6d38ed4dcc88c12d6fcb03bd9295 chromium-widevine.patch"