aboutsummaryrefslogtreecommitdiffstats
path: root/community/chromium/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-01-02 15:55:53 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-02 15:57:10 +0100
commit171287a30eeb0cb92290dad094ffd3bc41f9e9c6 (patch)
treed13612273caf29fa98a37377d728eb972190e19f /community/chromium/APKBUILD
parent52c531d4b9b061dfced2844b15df5c5e3d2a1b43 (diff)
downloadaports-171287a30eeb0cb92290dad094ffd3bc41f9e9c6.tar.bz2
aports-171287a30eeb0cb92290dad094ffd3bc41f9e9c6.tar.xz
community/chromium: build with vaapi and dont use gold
gold does not seem to work with arm architectures. libva patches are from void linux
Diffstat (limited to 'community/chromium/APKBUILD')
-rw-r--r--community/chromium/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 01944bc3bf..cffbe543d5 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
pkgver=71.0.3578.98
-pkgrel=1
+pkgrel=2
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64 aarch64 armhf armv7"
@@ -109,6 +109,8 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
chromium-71-gcc-0.patch
gcc8-alignof.patch
chromium-fix_harfbuzz_2.patch
+ chromium-enable-vaapi.patch
+ chromium-i686-vaapi-fpermissive.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -171,12 +173,6 @@ prepare() {
-delete
done
- # Work around bug in blink in which GCC 6 optimizes away null pointer checks
- # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833524
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68853#c2
- sed -i '/config("compiler")/ a cflags_cc = [ "-fno-delete-null-pointer-checks" ]' \
- build/config/linux/BUILD.gn
-
msg "Replacing gyp files"
python build/linux/unbundle/replace_gn_files.py --system-libraries \
${use_system}
@@ -198,13 +194,6 @@ build() {
eval "$(base64 -d < $srcdir/google-api.keys)"
local _ca=""
- #case "$CARCH" in
- # Chromium build as armv6 is broken, ffmpeg fails utterly
- # The default is armv7 which is not armhf standard, but better than nothing.
- #armhf) _ca=$(_gn_flags arm_version=6 arm_arch=\"armv6zk\" \
- # arm_fpu=\"vfp\" arm_float_abi=\"hard\" \
- # arm_use_neon=false arm_optionally_use_neon=true);;
- #esac
msg "Bootstrapping GN"
local _c=$(_gn_flags is_clang=false \
@@ -212,9 +201,10 @@ build() {
treat_warnings_as_errors=false \
fatal_linker_warnings=false \
binutils_path=\"/usr/bin\" \
- use_gold=true \
+ use_gold=false \
use_allocator=\"none\" \
use_allocator_shim=false \
+ use_vaapi=true \
)
AR="ar" CC="${CC:-gcc}" CXX="${CXX:-g++}" LD="${CXX:-g++}" \
@@ -225,7 +215,6 @@ build() {
clang_use_chrome_plugins=false \
custom_toolchain=\"//build/toolchain/linux/unbundle:default\" \
enable_hangout_services_extension=true \
- enable_hotwording=false \
enable_nacl=false \
enable_nacl_nonsfi=false \
enable_precompiled_headers=false \
@@ -240,6 +229,7 @@ build() {
icu_use_data_file=true \
is_clang=false \
is_debug=$_is_debug \
+ is_desktop_linux=true \
linux_use_bundled_binutils=false \
proprietary_codecs=true \
remove_webcore_debug_symbols=true \
@@ -250,7 +240,7 @@ build() {
use_cups=true \
use_custom_libcxx=false \
use_gnome_keyring=false \
- use_gold=true \
+ use_gold=false \
use_lld=false \
use_pulseaudio=false \
use_sysroot=false \
@@ -272,6 +262,9 @@ build() {
paxmark -m out/Release/v8_context_snapshot_generator \
out/Release/obj/tools/v8_context_snapshot/v8_context_snapshot_generator
+ # final link needs lots of file descriptors
+ ulimit -n 2048
+
# finish rest of the build
ninja -C out/$_buildtype chrome chrome_sandbox chromedriver
}
@@ -357,4 +350,6 @@ cbd99d51178fa5c2c3dee1eb4990240ca2ff829cee9151384e36bc3c634698c0ecaf9b51c99e901f
05c1af43038f76014f5f8b605085310414242f2bfad0e3258ddb29a08e7f4307de31b2d551b0a291986cc7d5a01cf3a003ac864216877195bb4310fd33193f0f musl-crashpad.patch
74fcae35afd964e2dc09508325465ee0d2efd13b94941eaf6464da1f4b32a34b326cf2c290fffcfc930acefda51a64dfbc980527900849efb5a94922cc17bc20 chromium-71-gcc-0.patch
9bfc532fd1e84e30362ac41fcd68253e17ee4cb5e986ceb5bb122e3235e4617e295ce9dddfdfbbd0b9d3e67267096152da2a19e3bb4bb9111c7fdb22fa398872 gcc8-alignof.patch
-4e6bfecdece829306b8c2ea2a4b6d9b0598f97e5b164e0f468e765ffa10cac6b9e57c8814b79eb1244a314d81e8954654111a2e1e056b2c450b369994337cb40 chromium-fix_harfbuzz_2.patch"
+4e6bfecdece829306b8c2ea2a4b6d9b0598f97e5b164e0f468e765ffa10cac6b9e57c8814b79eb1244a314d81e8954654111a2e1e056b2c450b369994337cb40 chromium-fix_harfbuzz_2.patch
+b0e61b4710a8e9009bd9c10722d902391b83c0400a48a6a40cc0e117ca4c1895732babe5baa078f5b3096b72d105fa2d1f4196f8d35c1ae94ff4d8d99d2a17f5 chromium-enable-vaapi.patch
+42d64d07215476295a35568e4492297a00b66205b5a41288a98b1663985fe1868e9595e961284dfbbd8b5846cc1b04e365ab89733270ffbc6967e3366571cf47 chromium-i686-vaapi-fpermissive.patch"