aboutsummaryrefslogtreecommitdiffstats
path: root/community/chromium
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-08-28 02:43:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-08-28 02:48:24 +0000
commit4321d98a3c9eed570fe04872e5d133c5d011be92 (patch)
tree29b939fa9c133b448c5d40802f869a87b27f7fe5 /community/chromium
parent712aae449ebc46ea0fb31db103ced0633a958df1 (diff)
downloadaports-4321d98a3c9eed570fe04872e5d133c5d011be92.tar.bz2
aports-4321d98a3c9eed570fe04872e5d133c5d011be92.tar.xz
community/chromium: upgrade to 52.0.2743.116
Diffstat (limited to 'community/chromium')
-rw-r--r--community/chromium/APKBUILD94
-rw-r--r--community/chromium/chromium-use-non-versioned-icu-namespace.patch14
-rw-r--r--community/chromium/fix-png-decoder-build.patch11
-rw-r--r--community/chromium/musl-fixes.patch22
-rw-r--r--community/chromium/musl-sandbox.patch16
-rw-r--r--community/chromium/no-execinfo.patch80
-rw-r--r--community/chromium/no-mallinfo.patch38
7 files changed, 133 insertions, 142 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 4e7d480e74..e472248c05 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
-pkgver=49.0.2623.110
-pkgrel=1
+pkgver=52.0.2743.116
+pkgrel=0
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64"
@@ -11,7 +11,7 @@ depends="xdg-utils"
depends_dev=""
makedepends="$depends_dev alsa-lib-dev libevent-dev libpng-dev jpeg-dev
cairo-dev cups-dev mesa-dev libcap-dev dbus-glib-dev gtk+-dev
- libxml2-dev freetype-dev jpeg-dev libxslt-dev libxtst-dev icu-dev
+ libxml2-dev freetype-dev jpeg-dev libxslt-dev libxtst-dev
flac-dev speex-dev hunspell-dev libxinerama-dev ffmpeg-dev nss-dev
libwebp-dev bzip2-dev libvpx-dev sqlite-dev libelf-dev libgcrypt-dev
zlib-dev gnutls-dev mesa-dev libxcursor-dev libxcomposite-dev krb5-dev
@@ -34,14 +34,15 @@ source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
no-mallinfo.patch
no-getcontext.patch
musl-sandbox.patch
+ fix-png-decoder-build.patch
chromium-system-jinja-r7.patch
chromium-widevine.patch
-
+
musl-hacks.patch
"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
case "${CARCH}" in
x86_64) target_arch=x64;;
@@ -50,20 +51,20 @@ case "${CARCH}" in
esac
prepare() {
- cd "$_builddir"
-
+ cd "$builddir"
+
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
-
+
# Remove bundled ICU; its header files appear to get picked up instead of
# the system ones, leading to errors during the final link stage.
# https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
- find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
+ #find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
# https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/9JX1N2nf4PU/discussion
touch chrome/test/data/webui/i18n_process_css_test.html || return 1
@@ -71,10 +72,10 @@ prepare() {
}
build() {
- cd "$_builddir"
-
+ cd "$builddir"
+
# currently does not build with system vpx 1.4
- # remoting/codec/video_encoder_vpx.cc:308:10: error:
+ # remoting/codec/video_encoder_vpx.cc:308:10: error:
# 'vpx_codec_control_VP9E_GET_ACTIVEMAP' was not declared in this scope
local vpx=0
# reusable system library settings
@@ -82,25 +83,25 @@ build() {
-Duse_system_bzip2=1
-Duse_system_flac=1
-Duse_system_harfbuzz=1
- -Duse_system_icu=1
+ -Duse_system_icu=0
-Duse_system_jsoncpp=1
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
-Duse_system_libvpx=$vpx
+ -Duse_system_libwebp=1
-Duse_system_libxml=1
- -Duse_system_snappy=1
- -Duse_system_xdg_utils=1
- -Duse_system_yasm=1
+ -Duse_system_libxslt=1
+ -Duse_system_minizip=1
-Duse_system_nspr=1
-Duse_system_re2=1
+ -Duse_system_snappy=1
-Duse_system_speex=1
- -Duse_system_libwebp=1
- -Duse_system_libxslt=1
+ -Duse_system_xdg_utils=1
+ -Duse_system_yasm=1
-Duse_system_zlib=1
- -Duse_system_minizip=1
"
-
+
msg "Replacing gyp files"
build/linux/unbundle/replace_gyp_files.py ${use_system} || return 1
@@ -120,6 +121,7 @@ build() {
-Dwerror= \
-Dclang=0 \
-Dpython_ver=2.7 \
+ -Dlinux_link_cups=1 \
-Dlinux_link_gsettings=1 \
-Dlinux_link_libpci=1 \
-Dlinux_link_libspeechd=0 \
@@ -127,12 +129,13 @@ build() {
-Dlinux_use_bundled_binutils=0 \
-Dlinux_use_bundled_gold=0 \
-Dlinux_use_gold_flags=0 \
- -Dicu_use_data_file_flag=0 \
+ -Dicu_use_data_file_flag=1 \
-Dlogging_like_official_build=1 \
-Dlibspeechd_h_prefix=speech-dispatcher/ \
-Dffmpeg_branding=Chrome \
-Dproprietary_codecs=1 \
-Duse_allocator=none \
+ -Duse_experimental_allocator_shim=false \
-Duse_gnome_keyring=0 \
-Dusb_ids_path=/usr/share/hwdata/usb.ids \
-Duse_mojo=0 \
@@ -160,15 +163,15 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
local bin pak
for bin in chrome natives_blob.bin snapshot_blob.bin; do
install -Dm755 out/Release/$bin \
- "$pkgdir"/usr/lib/$pkgname/$bin || return 1
+ "$pkgdir"/usr/lib/$pkgname/$bin || return 1
done
- install -Dm4755 "$_builddir"/out/Release/chrome_sandbox \
+ install -Dm4755 "$builddir"/out/Release/chrome_sandbox \
"$pkgdir"/usr/lib/$pkgname/chrome-sandbox || return 1
for pak in out/Release/*.pak; do
@@ -178,7 +181,7 @@ package() {
install -Dm755 "$srcdir"/chromium-launcher.sh \
"$pkgdir"/usr/lib/$pkgname/chromium-launcher.sh || return 1
-
+
cp -r out/Release/locales "$pkgdir"/usr/lib/$pkgname/ || return 1
install -Dm644 out/Release/chrome.1 \
@@ -186,7 +189,7 @@ package() {
install -Dm644 out/Release/chrome.1 \
"$pkgdir"/usr/share/man/man1/chromium.1 || return 1
-
+
# It is important that we name the target "chromium-browser",
# xdg-utils expect it; bug #355517.
mkdir -p "$pkgdir"/usr/bin || return 1
@@ -194,7 +197,7 @@ package() {
ln -sf /usr/lib/$pkgname/chromium-launcher.sh \
chromium-browser || return 1
ln -sf /usr/lib/$pkgname/chromedriver || return 1
- cd "$_builddir"
+ cd "$builddir"
install -Dm644 "$srcdir"/chromium.conf \
"$pkgdir"/etc/chromium/chromium.conf || return 1
@@ -215,49 +218,52 @@ package() {
chromedriver() {
pkgdesc="WebDriver driver for the Chromium Browser"
- install -Dm755 "$_builddir"/out/Release/chromedriver \
+ install -Dm755 "$builddir"/out/Release/chromedriver \
"$subpkgdir"/usr/lib/$pkgname/chromedriver || return 1
}
-md5sums="7fd11db62370c23db681ca6e09e2e633 chromium-49.0.2623.110.tar.xz
+md5sums="9c1c9aefe72876865800952c20b25d5e chromium-52.0.2743.116.tar.xz
b6d015c1da85aa65ee21bc974c7fc7d2 chromium-launcher.sh
c5aa73a87d4b88cce9f1a680ca691bb6 chromium.conf
2962ac6259e39a797d441daf43aa49c9 chromium.desktop
2d2ee5f22d65c756871301b4a407f4ca google-api.keys
-8d28a0bf8315bbc796fe04a5d94c90a7 musl-fixes.patch
-00ae59dd9d09c60a116fd0133f9f3a60 no-execinfo.patch
+eb7ce3cac0fde703474cb127b63ba705 musl-fixes.patch
+6723002017d7103639d919e2cd053fbe no-execinfo.patch
f99a4572c0be2c2123acc2478905e01f resolver.patch
-68befd7a58485973e15ca8a3263112d7 no-mallinfo.patch
+4b69f969c7b959348cf5b10ca05eca97 no-mallinfo.patch
2c8de771a7c0e5e0e9fc68fa978785f7 no-getcontext.patch
-72f430ba7a83b32c0046152bc8c13a60 musl-sandbox.patch
+c805e026abc748d9925fab8250760bcc musl-sandbox.patch
+e9add89e4b83b2a907f7f9bf7fc70836 fix-png-decoder-build.patch
97b1578585ab600ed9adef4f341ccd80 chromium-system-jinja-r7.patch
de717d6430532f34fe161035dfdafcdf chromium-widevine.patch
5f1bca53835b6380b5949c96860f6894 musl-hacks.patch"
-sha256sums="41840925d3769555ce4ebd780ee0dc6789ffae27b1684006c9b543bcaa35bbd2 chromium-49.0.2623.110.tar.xz
+sha256sums="a194ae1edb041024b3d4b6ba438f32fefdb6f1ecb24a96c50248a486b237a101 chromium-52.0.2743.116.tar.xz
89f1eb19d1ed998a190045ea173959f01faee3490d58a6a34ca3fe21228e569f chromium-launcher.sh
b466559340a36998354a0577325fe533d9e6b74c24a15b7599671171506bf128 chromium.conf
3ae90cea7503d0039de53448ed112b9bc0cb5a09f6b0045506eb777fc23517e5 chromium.desktop
267ba8ff50574e51d2582c4fca9b9e14f7225c1fa064d135cbceff9cef2324ac google-api.keys
-42e800f6cc223593188e977ab4e7010cda253204d91bace548c338578674804a musl-fixes.patch
-505a55c28e971e067f189e3a1ce697d711cec82a765d81f78eb49ec1f6df56cf no-execinfo.patch
+a620b4492cb28e4b0d571ba3b79ec7635506f297824d390167ec7391f23eb27e musl-fixes.patch
+1bc3edae8d591b7fc89d9b45d159b35f45d628bcdf8ede0684877cb2ee1c7405 no-execinfo.patch
914c513bb54d4d97cd2a7622647f6af5cd0c8d29a0aa2962a60fdbed88f54429 resolver.patch
-6834c9a0623dc632baecb274ae9a8e7c0eca08b07268875d59a117dce16ae29e no-mallinfo.patch
+633885c9af2b2f635e93ab0dbaa76eb72cb87d030b237459e82d35400999af83 no-mallinfo.patch
ea79f9a46116c8b56bbc69d226abd9252e4ae4d946ca695203f2298279cc2211 no-getcontext.patch
-16a3986a3ae9f662b27b2b8fb5d10e8a5afc84f183eb3cf4ab1cd8b8499744e0 musl-sandbox.patch
+3d0303f9ea04b2c24e16068ea2d423fce0e37ebb2b89dde342f9e8f9d0b149b4 musl-sandbox.patch
+1c3d7fb85c09f289efb971285f50ef7ecfbc2c0bf0d063da45ce2edb1c69e69a fix-png-decoder-build.patch
872f5a38d8263b14308bb117828496a4093d0e6ad755d39d2c5e6857314fe071 chromium-system-jinja-r7.patch
1d1ead77250475228524770e57c17282aff9098c5efc3d7719b0df76229b8874 chromium-widevine.patch
10a4d81e1d8f70e4993ba0b7e1b9069f18c28190e6660e0f67bf24d598aa7c66 musl-hacks.patch"
-sha512sums="d945cc26ddb6b7c6f159206f34db5698917312245b3967b9b2a8e909262ed36e235bd35554e62864bed3e1de0038649fa72756b910480d48b8c62cbf37d53ccd chromium-49.0.2623.110.tar.xz
+sha512sums="c9a8b6d7a22d3b086f1761678f1fa047191a8e44bc6ebe8745e76ea92420b1330fc6e4134ca7bc22c0367e7a25df04900156d0ebb44eae3ef7f98d1deb5362e5 chromium-52.0.2743.116.tar.xz
b9a810416dd7a8ffc3a5ced85ad9acebda1665bd08a57eec7b189698cc5f74d2c3fd69044e20fcb83297a43214b2772a1312b2c6122ea0eb716abacf39524d60 chromium-launcher.sh
f6d962b9e4c22dd42183df3db5d3202dab33eccecafb1bf63ca678147289581262db1e5e64cbe8f9c212beefb0a6717bb8d311e497f56b55fe95b8bab2db493f chromium.conf
e182c998a43d22d1c76a86c561619afd1fca8c2be668265ad5e2f81a3806f7a154272cc027a2f8b370fb69446892c69e5967a4be76082325c14245ee7915234c chromium.desktop
2d8237a940ea691bd10b08315429677a587f7ef9692a0cca53bfd066eae82998a6c71f402a8669e9de39f94d7f3280745d1628ea6eac5d76ca7116844d4e0dac google-api.keys
-0d112ce486fd3b93ef60eadbc4db7f1746c51bc02634212ce986f34480915ea37f4ca8ff37d56316abecb112bb0fc1079e7bc27e603ec9ceabde01caa2777561 musl-fixes.patch
-4f756d3e404033f7a36b38266176b7302f7e2a2e78c9f8b8d362a53a3dbdc675cdaa581393a70c23a29135b34566cf4109513cb13a289dc111bbce65ec065ebd no-execinfo.patch
+a81c323024537e02f03e3d7cfd62f7a3e0ceb6d2534d1a6169841fc58a1ccdf106ab942151b0124333b23a8955fbf6d0bc18b6dc64e9ff4cfd070abc3dd20253 musl-fixes.patch
+0d0b69dcc4779f5a6e9820513e35d94c8959f8f57a8a3f9d2a63b0d48222526fc6657d6f3d23eafbf1cb2f9ad3a5d3d6f1e6b0ca7d20f17b7459979a1c5390cf no-execinfo.patch
d60407a8faadfd2a8294570163b4d1b1112c8a70a6f8e778fc3aff25d20613a2e26c66cd87e69c54953cc1b984e4038015ad04797b0495df13932541b05398fe resolver.patch
-170173a05167cb073403501c9dc57bb86c2f77d54bcabf970cb1beb2302f848dc21a89c3406940b0156b94dfb20c12e2d2bdb73064613a28bc3af39ba1f453b5 no-mallinfo.patch
+286f8bf4941c62b691059ad7cc1ec446a5b6ca3e4c740ecb7bd2ab1fab2e77b538bc975c6d7941b006380574758b584aa02aae3878092ac477aa0427d7d35e18 no-mallinfo.patch
42d9a6ebea2d95cdc169b921cc1a1b846cf500997059fd3084de09e21f00b63b76e60c6124f4af247d402ff5ca3f4bf8867a6f2c78198c05b4273ca01fb29241 no-getcontext.patch
-2f5a54bf952eeecced66dc3711f11802a5c00854d0dc546f13b37a63804809233ac7ea52c56e18cc652794cb2dd7dfcf2a8f67097e1f20d9b1e85ce2e2d14654 musl-sandbox.patch
+ce8276bb35a8d72cf58868a6331e85286b350a1aad694525ebf637499819219dd4d87ab67dd3b938830a6bd3e7172fc9bcd9c8971820d0ed95c0d141867a24fe musl-sandbox.patch
+87bd7bbe2d16e6c3ad24310d6bfd5170c878f206f5bd132348f6afbad3447f44e015a9f655cce51d221d365f28cc6eec3bfc333fa4afc4bef8c9f3fcb7700fff fix-png-decoder-build.patch
10bcc6a467b6766d13b5e41e7b7dcdbd62de7c04daad16c83037e88043032a0c118627029f91ef8a2a57faaaebc8b6f4ee16e8d1fecb5921d0d49efd60a27863 chromium-system-jinja-r7.patch
4a11b46afa8ce84bd23a8c506301b5848ee4291a764f3aed282b8a98706ece16cf9346dec6cc71b1e17812b15f43a5cbc7bc6d38ed4dcc88c12d6fcb03bd9295 chromium-widevine.patch
4043dd7a64dcb9b73e15786b407934dd1b171df8b628ab1b18718fd93f9758c76eb25d1bdf1e1a22901544185088b8f817d3e2a58154c54949704dc8cc87b84d musl-hacks.patch"
diff --git a/community/chromium/chromium-use-non-versioned-icu-namespace.patch b/community/chromium/chromium-use-non-versioned-icu-namespace.patch
deleted file mode 100644
index f7b0b6d805..0000000000
--- a/community/chromium/chromium-use-non-versioned-icu-namespace.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: components/autofill/core/common/autofill_l10n_util.cc
-diff --git a/components/autofill/core/common/autofill_l10n_util.cc b/components/autofill/core/common/autofill_l10n_util.cc
-index 2ee517faf82b1feb224f83ae533092ae3b31f5af..c29b0a299b7215895874adf9241e4705247161ab 100644
---- a/components/autofill/core/common/autofill_l10n_util.cc
-+++ b/components/autofill/core/common/autofill_l10n_util.cc
-@@ -22,7 +22,7 @@ CaseInsensitiveCompare::CaseInsensitiveCompare(const icu::Locale& locale) {
- // library. This could be due to a device-specific issue (has been seen in
- // the wild on Android devices). In the failure case, |collator_| will be
- // null. See http://crbug.com/558625.
-- icu_54::UnicodeString name;
-+ icu::UnicodeString name;
- std::string locale_name;
- locale.getDisplayName(name).toUTF8String(locale_name);
- LOG(ERROR) << "Failed to initialize the ICU Collator for "
diff --git a/community/chromium/fix-png-decoder-build.patch b/community/chromium/fix-png-decoder-build.patch
new file mode 100644
index 0000000000..bc031cea03
--- /dev/null
+++ b/community/chromium/fix-png-decoder-build.patch
@@ -0,0 +1,11 @@
+--- a/third_party/WebKit/Source/platform/image-decoders/png/PNGImageDecoder.cpp.orig 2016-06-01 17:42:30.396115414 +0200
++++ b/third_party/WebKit/Source/platform/image-decoders/png/PNGImageDecoder.cpp 2016-06-01 17:43:05.182117208 +0200
+@@ -234,7 +234,7 @@
+ #endif
+ png_uint_32 profileLength = 0;
+ if (png_get_iCCP(png, info, &profileName, &compressionType, &profile, &profileLength)) {
+- setColorProfileAndTransform(profile, profileLength, imageHasAlpha, false /* useSRGB */);
++ setColorProfileAndTransform((const char*) profile, profileLength, imageHasAlpha, false /* useSRGB */);
+ }
+ }
+ #endif // PNG_iCCP_SUPPORTED
diff --git a/community/chromium/musl-fixes.patch b/community/chromium/musl-fixes.patch
index 1410502b3b..62692503fb 100644
--- a/community/chromium/musl-fixes.patch
+++ b/community/chromium/musl-fixes.patch
@@ -186,16 +186,6 @@
UMA_HISTOGRAM_ENUMERATION("Linux.WindowManager",
GetLinuxWindowManager(),
UMA_LINUX_WINDOW_MANAGER_COUNT);
---- ./third_party/ffmpeg/libavutil/autorename_libavutil_cpu.c.orig
-+++ ./third_party/ffmpeg/libavutil/autorename_libavutil_cpu.c
-@@ -38,7 +38,6 @@
- #include <sys/param.h>
- #endif
- #include <sys/types.h>
--#include <sys/sysctl.h>
- #endif
- #if HAVE_UNISTD_H
- #include <unistd.h>
--- ./device/serial/serial_io_handler_posix.cc.orig
+++ ./device/serial/serial_io_handler_posix.cc
@@ -6,6 +6,7 @@
@@ -217,3 +207,15 @@
if (severity_ == LOG_FATAL && !base::debug::BeingDebugged()) {
// Include a stack trace on a fatal, unless a debugger is attached.
base::debug::StackTrace trace;
+diff --git a/third_party/ots/include/opentype-sanitiser.h b/third_party/ots/include/opentype-sanitiser.h
+index a80ea16..55a2abf 100644
+--- a/third_party/ots/include/opentype-sanitiser.h
++++ b/third_party/ots/include/opentype-sanitiser.h
+@@ -20,6 +20,7 @@ typedef unsigned __int64 uint64_t;
+ #define htonl(x) _byteswap_ulong (x)
+ #define htons(x) _byteswap_ushort (x)
+ #else
++#include <sys/types.h>
+ #include <arpa/inet.h>
+ #include <stdint.h>
+ #endif
diff --git a/community/chromium/musl-sandbox.patch b/community/chromium/musl-sandbox.patch
index 9a6cad4f0f..4414670cba 100644
--- a/community/chromium/musl-sandbox.patch
+++ b/community/chromium/musl-sandbox.patch
@@ -32,22 +32,6 @@
}
--- ./sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc.orig
+++ ./sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
-@@ -416,12 +416,12 @@
- #endif
- case __NR_epoll_create1:
- case __NR_epoll_ctl:
-+ case __NR_epoll_pwait:
- return true;
- default:
- #if defined(__x86_64__)
- case __NR_epoll_ctl_old:
- #endif
-- case __NR_epoll_pwait:
- #if defined(__x86_64__)
- case __NR_epoll_wait_old:
- #endif
---- ./sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc.orig
-+++ ./sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
@@ -494,6 +494,7 @@
case __NR_mlock:
case __NR_munlock:
diff --git a/community/chromium/no-execinfo.patch b/community/chromium/no-execinfo.patch
index bc5eefcd55..fd4ced7deb 100644
--- a/community/chromium/no-execinfo.patch
+++ b/community/chromium/no-execinfo.patch
@@ -1,103 +1,121 @@
---- ./base/debug/stack_trace_posix.cc.orig
-+++ ./base/debug/stack_trace_posix.cc
-@@ -22,7 +22,7 @@
+--- a/base/debug/stack_trace_posix.cc.orig 2016-05-08 07:59:51.749087517 +0200
++++ b/base/debug/stack_trace_posix.cc 2016-05-08 08:01:24.988950619 +0200
+@@ -24,7 +24,7 @@
#if defined(__GLIBCXX__)
#include <cxxabi.h>
#endif
-#if !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBC__)
#include <execinfo.h>
#endif
-@@ -73,7 +73,7 @@
+@@ -75,7 +75,7 @@ void DemangleSymbols(std::string* text)
// Note: code in this function is NOT async-signal safe (std::string uses
// malloc internally).
-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(__GLIBCXX__) && defined(HAVE_BACKTRACE)
++#if defined(__GLIBCXX__) && defined(__GLIBC__)
std::string::size_type search_from = 0;
while (search_from < text->size()) {
-@@ -169,7 +169,7 @@
+@@ -112,7 +112,7 @@ void DemangleSymbols(std::string* text)
+ }
+ }
+
+-#endif // defined(__GLIBCXX__) && !defined(__UCLIBC__)
++#endif // defined(__GLIBCXX__) && defined(__GLIBC__)
+ }
+ #endif // !defined(USE_SYMBOLIZE)
+
+@@ -124,7 +124,7 @@ class BacktraceOutputHandler {
+ virtual ~BacktraceOutputHandler() {}
+ };
- handler->HandleOutput("\n");
+-#if !defined(__UCLIBC__)
++#if defined(__GLIBC__)
+ void OutputPointer(void* pointer, BacktraceOutputHandler* handler) {
+ // This should be more than enough to store a 64-bit number in hex:
+ // 16 hex digits + 1 for null-terminator.
+@@ -201,7 +201,7 @@ void ProcessBacktrace(void *const *trace
}
--#elif !defined(__UCLIBC__)
-+#elif defined(HAVE_BACKTRACE)
- bool printed = false;
+ #endif // defined(USE_SYMBOLIZE)
+ }
+-#endif // !defined(__UCLIBC__)
++#endif // defined(__GLIBC__)
- // Below part is async-signal unsafe (uses malloc), so execute it only
-@@ -738,7 +738,7 @@
+ void PrintToStderr(const char* output) {
+ // NOTE: This code MUST be async-signal safe (it's used by in-process
+@@ -716,7 +716,7 @@ StackTrace::StackTrace() {
// NOTE: This code MUST be async-signal safe (it's used by in-process
// stack dumping signal handler). NO malloc or stdio is allowed here.
-#if !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBC__)
// Though the backtrace API man page does not list any possible negative
// return values, we take no chance.
count_ = base::saturated_cast<size_t>(backtrace(trace_, arraysize(trace_)));
-@@ -751,13 +751,13 @@
+@@ -729,13 +729,13 @@ void StackTrace::Print() const {
// NOTE: This code MUST be async-signal safe (it's used by in-process
// stack dumping signal handler). NO malloc or stdio is allowed here.
-#if !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBC__)
PrintBacktraceOutputHandler handler;
ProcessBacktrace(trace_, count_, &handler);
#endif
}
-#if !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBC__)
void StackTrace::OutputToStream(std::ostream* os) const {
StreamBacktraceOutputHandler handler(os);
ProcessBacktrace(trace_, count_, &handler);
---- ./third_party/WebKit/Source/wtf/Assertions.cpp.orig
-+++ ./third_party/WebKit/Source/wtf/Assertions.cpp
-@@ -61,7 +61,7 @@
- #define HAVE_ISDEBUGGERPRESENT 1
+--- a/third_party/WebKit/Source/wtf/Assertions.cpp.orig 2016-05-08 08:02:03.230553120 +0200
++++ b/third_party/WebKit/Source/wtf/Assertions.cpp 2016-05-08 08:02:35.822504255 +0200
+@@ -60,7 +60,7 @@
+ #include <windows.h>
#endif
-#if OS(MACOSX) || (OS(LINUX) && !defined(__UCLIBC__))
-+#if defined(HAVE_BACKTRACE)
++#if OS(MACOSX) || (OS(LINUX) && defined(__GLIBC__))
#include <cxxabi.h>
#include <dlfcn.h>
#include <execinfo.h>
-@@ -222,7 +222,7 @@
+@@ -220,7 +220,7 @@ void WTFReportArgumentAssertionFailure(c
void WTFGetBacktrace(void** stack, int* size)
{
-#if OS(MACOSX) || (OS(LINUX) && !defined(__UCLIBC__))
-+#if defined(HAVE_BACKTRACE)
++#if OS(MACOSX) || (OS(LINUX) && defined(__GLIBC__))
*size = backtrace(stack, *size);
#elif OS(WIN)
// The CaptureStackBackTrace function is available in XP, but it is not defined
-@@ -260,7 +260,7 @@
+@@ -258,7 +258,7 @@ FrameToNameScope::FrameToNameScope(void*
: m_name(0)
, m_cxaDemangled(0)
{
-#if OS(MACOSX) || (OS(LINUX) && !defined(__UCLIBC__))
-+#if defined(HAVE_BACKTRACE)
++#if OS(MACOSX) || (OS(LINUX) && defined(__GLIBC__))
Dl_info info;
if (!dladdr(addr, &info) || !info.dli_sname)
return;
---- ./third_party/webrtc/base/checks.cc.orig
-+++ ./third_party/webrtc/base/checks.cc
+--- a/third_party/webrtc/base/checks.cc.orig 2016-05-08 08:03:04.398461275 +0200
++++ b/third_party/webrtc/base/checks.cc 2016-05-08 08:03:24.254431362 +0200
@@ -16,7 +16,7 @@
#include <cstdio>
#include <cstdlib>
-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBCXX__) && defined(__GLIBC__)
#include <cxxabi.h>
#include <execinfo.h>
#endif
-@@ -55,7 +55,7 @@
+@@ -55,7 +55,7 @@ void PrintError(const char* format, ...)
// to get usable symbols on Linux. This is copied from V8. Chromium has a more
// advanced stace trace system; also more difficult to copy.
void DumpBacktrace() {
-#if defined(__GLIBCXX__) && !defined(__UCLIBC__)
-+#if defined(HAVE_BACKTRACE)
++#if defined(__GLIBCXX__) && defined(__GLIBC__)
void* trace[100];
int size = backtrace(trace, sizeof(trace) / sizeof(*trace));
char** symbols = backtrace_symbols(trace, size);
diff --git a/community/chromium/no-mallinfo.patch b/community/chromium/no-mallinfo.patch
index be571d40ad..965cddb2eb 100644
--- a/community/chromium/no-mallinfo.patch
+++ b/community/chromium/no-mallinfo.patch
@@ -1,38 +1,22 @@
---- ./base/trace_event/malloc_dump_provider.cc.orig
-+++ ./base/trace_event/malloc_dump_provider.cc
-@@ -61,7 +61,7 @@
+--- a/base/trace_event/malloc_dump_provider.cc.orig 2016-05-08 08:04:01.166374018 +0200
++++ b/base/trace_event/malloc_dump_provider.cc 2016-05-08 08:05:07.846264723 +0200
+@@ -61,7 +61,7 @@ bool MallocDumpProvider::OnMemoryDump(co
// fixed quantum, so the excess region will not be resident.
// See crrev.com/1531463004 for detailed explanation.
resident_size = stats.max_size_in_use;
-#else
-+#elif defined(__GLIBC__)
++#elif defined(OS_LINUX) && defined(__GLIBC__)
struct mallinfo info = mallinfo();
DCHECK_GE(info.arena + info.hblkhd, info.uordblks);
-@@ -73,6 +73,7 @@
- allocated_objects_size = info.uordblks;
- #endif
-
-+#if defined(USE_TCMALLOC) || defined(__GLIBC__) || defined(OS_MACOSX) || defined(OS_IOS)
- MemoryAllocatorDump* outer_dump = pmd->CreateAllocatorDump("malloc");
- outer_dump->AddScalar("virtual_size", MemoryAllocatorDump::kUnitsBytes,
- total_virtual_size);
-@@ -95,6 +96,7 @@
- MemoryAllocatorDump::kUnitsBytes,
- resident_size - allocated_objects_size);
- }
-+#endif
-
- return true;
- }
---- ./content/child/content_child_helpers.cc
-+++ ./content/child/content_child_helpers.cc
-@@ -18,7 +18,7 @@
-
- namespace content {
-
+--- a/content/child/content_child_helpers.cc.orig 2016-05-08 08:05:37.415219394 +0200
++++ b/content/child/content_child_helpers.cc 2016-05-08 08:06:27.110142484 +0200
+@@ -24,7 +24,7 @@ namespace content {
+ // though, this provides only a partial and misleading value.
+ // Unfortunately some telemetry benchmark rely on it and these need to
+ // be refactored before getting rid of this. See crbug.com/581365 .
-#if defined(OS_LINUX) || defined(OS_ANDROID)
-+#if defined(_GLIBC_) || defined(OS_ANDROID)
++#if defined(OS_LINUX) && defined(__GLIBC__) || defined(OS_ANDROID)
size_t GetMemoryUsageKB() {
struct mallinfo minfo = mallinfo();
uint64_t mem_usage =