aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloc/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-02-10 18:13:54 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-02-11 14:55:58 +0100
commit7fbf069a416132381a377191b916acb5da720a92 (patch)
treeb03774fe0b302a43b479b7c0e33911e8b9ab3a19 /community/cloc/APKBUILD
parent984ecb3421fb2877c357c3dd8590b872707dbb8c (diff)
downloadaports-7fbf069a416132381a377191b916acb5da720a92.tar.bz2
aports-7fbf069a416132381a377191b916acb5da720a92.tar.xz
community/cloc: upgrade to 1.76
Diffstat (limited to 'community/cloc/APKBUILD')
-rw-r--r--community/cloc/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/community/cloc/APKBUILD b/community/cloc/APKBUILD
index f76eb57125..dd992d9322 100644
--- a/community/cloc/APKBUILD
+++ b/community/cloc/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=cloc
-pkgver=1.74
-pkgrel=1
+pkgver=1.76
+pkgrel=0
pkgdesc="Count lines of code"
url="https://github.com/AlDanial/cloc"
arch="noarch"
@@ -11,7 +11,8 @@ depends="perl perl-algorithm-diff perl-regexp-common"
makedepends=""
subpackages="$pkgname-doc"
source="https://github.com/AlDanial/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
- disable-submodule-tests.patch"
+ disable-01_opts.patch
+ disable-test-perl.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -19,7 +20,10 @@ build() {
}
check() {
- make -C "$builddir"/Unix test
+ # test-perl requires perl-parallel-forkmanager which is
+ # currently in testing. Therefore we only run a subset of the
+ # testsuite for now.
+ make -B -C "$builddir"/Unix test-pod test-code
}
package() {
@@ -31,5 +35,6 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/
}
-sha512sums="456ff10c50673326e0b80d2e0b5965fba19c5c868e880108647d5182e048e62bdd734ce485386a561163d8dab81551101cbc5dcc13088400fe0a14ad500e1cbf cloc-1.74.tar.gz
-74a9e7db8ebe8194928682882d60fdaef9cb7a5cdadffe8e444f8e7b82338e0c7cb5a3da6b2ac4a2f922bc6a564234ec8426a824d1634db432c9eddd0206c003 disable-submodule-tests.patch"
+sha512sums="3f16f084be1828557e4120a8e41b276336ac240c5de4dc765066277d848ce9af20f31b36ec4beb863066d8b3e9287ea0e0b2a8f1abd15532957f53d2d3935ecd cloc-1.76.tar.gz
+10039c23d06f16f3c44427ee0f0e5d16dd05d2c5364145f57c1e5de94227387907f9ecebe7d42fc976599a8c1814e51d5f0a4eddef154222c5138cbcce777c4a disable-01_opts.patch
+db35af1184fbf03ba4089ae5e9fbfc868b82a0487ee1bf0a284e40faba356e91bcb725c682cbf52c8f76ed1d6883f9ce86200bb65cf8175f9630ebe1492c890e disable-test-perl.patch"