aboutsummaryrefslogtreecommitdiffstats
path: root/community/cloudi
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-04-04 13:05:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-17 11:45:40 +0000
commit00c8013e0f5891a742b1a1cf10a2536f80e84ffb (patch)
tree7e0f7fd9dc22436657dfb24dc37e9fde92f82b45 /community/cloudi
parentbb37c77fa375ec392039a2498a581f9c16cb79bd (diff)
downloadaports-00c8013e0f5891a742b1a1cf10a2536f80e84ffb.tar.bz2
aports-00c8013e0f5891a742b1a1cf10a2536f80e84ffb.tar.xz
community/cloudi: rebuild against python 3.7
Diffstat (limited to 'community/cloudi')
-rw-r--r--community/cloudi/0005-Disable-tests-for-aports-buildservers.patch4
-rw-r--r--community/cloudi/APKBUILD16
-rw-r--r--community/cloudi/python-3.7.patch18
3 files changed, 29 insertions, 9 deletions
diff --git a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch b/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
index 57be80a2ae..51b5a22a5b 100644
--- a/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
+++ b/community/cloudi/0005-Disable-tests-for-aports-buildservers.patch
@@ -1,5 +1,5 @@
---- src/rebar_src_test.config.in
-+++ src/rebar_src_test.config.in
+--- ./src/rebar_src_test.config.in
++++ ./src/rebar_src_test.config.in
@@ -8,8 +8,6 @@
{sub_dirs,
["lib/cloudi_core",
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index 02ed242118..5becc62718 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -29,7 +29,7 @@
pkgname=cloudi
pkgver=1.7.5
-pkgrel=2
+pkgrel=3
pkgdesc="Cloud computing framework for efficient, scalable, and stable soft-realtime event processing."
url="https://cloudi.org/"
license="MIT"
@@ -75,8 +75,9 @@ install=""
subpackages=""
source="https://osdn.net/dl/$pkgname/$pkgname-$pkgver.tar.gz
0005-Disable-tests-for-aports-buildservers.patch
+ python-3.7.patch
$pkgname.initd"
-builddir="$srcdir/cloudi-$pkgver/src"
+builddir="$srcdir/cloudi-$pkgver"
# configure additional dependencies based on the package architecture
CONFIGURE_ARGS=""
@@ -97,13 +98,13 @@ x86_64)
esac
prepare() {
- cd "$builddir"
default_prepare
+ cd "$builddir"/src
./autogen.sh
}
build() {
- cd "$builddir"
+ cd "$builddir"/src
export PATH="/usr/lib/jvm/java-1.8-openjdk/bin:$PATH"
LIBS="-lexecinfo" CLOUDI_PID_FILE="/run/cloudi.pid" ./configure \
--prefix=/usr \
@@ -121,17 +122,18 @@ build() {
}
check() {
- cd "$builddir"
+ cd "$builddir"/src
make ct
}
package() {
- cd "$builddir"
+ cd "$builddir"/src
make DESTDIR="$pkgdir" install
install -m755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname
}
sha512sums="6684f498b501b47f583c86bb949aec68db4f8f91dd57c352989b01792e871d7e3e3386e658d6b71791c2baf7fc618c67b4fd85487ff27a17ef6f495cad5f241f cloudi-1.7.5.tar.gz
-66138dcd01dab23c0866a31e8dfe70876f72f73b5d37de4d0531c150b0d402f392b88528da93e366d1430901f2462b11dfd84654f7874aaa14fc67ea5021dff6 0005-Disable-tests-for-aports-buildservers.patch
+d831cc9672c12f27cf958975d72a3cb02ca21e78347f278a840679ab89479f795aba5ff0378731f276863fc5a3237d1bd0f861ccedc41e77321a19d726da8ca9 0005-Disable-tests-for-aports-buildservers.patch
+020e7c08867e2d84e75eeee74b72f1d79de481fb2affb815f6780d8ce9777dfda2aff71a5af4c066dce334b63b55f05706dfe751379479c086f6e573aa1b9ee0 python-3.7.patch
053f860f656617012208a0e1909e43b2f8979d381a90d3fa5a745a9cf5021fe54556a641fef2badaa9955f2394d00e32183389cb9b501169dcbf8cbe4fbb0329 cloudi.initd"
diff --git a/community/cloudi/python-3.7.patch b/community/cloudi/python-3.7.patch
new file mode 100644
index 0000000000..189a835131
--- /dev/null
+++ b/community/cloudi/python-3.7.patch
@@ -0,0 +1,18 @@
+based on https://github.com/CloudI/CloudI/commit/a7d593e3aa84b157e9c6c2d49fa072c8756d884a
+
+diff --git a/src/api/python/cloudi_py.cpp b/src/api/python/cloudi_py.cpp
+index ad3124f7..0e38c880 100644
+--- a/src/api/python/cloudi_py.cpp
++++ b/src/api/python/cloudi_py.cpp
+@@ -752,8 +752,9 @@ class callback : public CloudI::API::function_object_c
+ {
+ Py_ssize_t response_size_tmp = 0;
+ #ifdef PYTHON_VERSION_3_3_COMPATIBLE
+- response = PyUnicode_AsUTF8AndSize(result,
+- &response_size_tmp);
++ response =
++ const_cast<char *>(PyUnicode_AsUTF8AndSize(
++ result, &response_size_tmp));
+ if (response == NULL)
+ {
+ PyErr_Print();